aboutsummaryrefslogtreecommitdiff
path: root/math/blitz++/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 18:08:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 18:08:11 +0000
commitbbefe05848efaa8d2c89fe1d4455c2ce1604710e (patch)
tree2e9e57f410d13cf5f8b48d4b7042a00bfcf118ad /math/blitz++/Makefile
parent09b251be4f5480eb32d5d2b2502623c648716039 (diff)
downloadports-bbefe05848efaa8d2c89fe1d4455c2ce1604710e.tar.gz
ports-bbefe05848efaa8d2c89fe1d4455c2ce1604710e.zip
Notes
Diffstat (limited to 'math/blitz++/Makefile')
-rw-r--r--math/blitz++/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 2366a9c01442..dcbed1cb8129 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -10,21 +10,26 @@ PORTNAME= blitz++
PORTVERSION= 0.6
CATEGORIES= math
MASTER_SITES= http://www.oonumerics.org/blitz/download/releases/
-DISTNAME= blitz-${PORTVERSION:S/b/beta/}
+DISTNAME= blitz-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= blas:${PORTSDIR}/math/blas
+LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="-lg2c"
-CONFIGURE_ARGS= --with-cxx=gcc --with-blas=${LOCALBASE}/lib \
- --enable-optimize --disable-debug
-USE_GMAKE= yes
+CONFIGURE_ARGS= --with-cxx=gcc --disable-debug --with-blas=${LOCALBASE}/lib
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
post-patch:
@${FIND} ${WRKSRC}/manual -name "Makefile.in" | ${XARGS} \
- ${REINPLACE_CMD} -e "s,[$$][(]prefix[)],\$$(datadir),"
+ ${REINPLACE_CMD} -e 's|[(]prefix[)]|(datadir)|g'
+ @${REINPLACE_CMD} -e 's|g++|\$${CXX}|g ; \
+ s|"-ftemplate-depth-30|"\$${CXXFLAGS} -ftemplate-depth-30|g ; \
+ s|-O2||g' ${WRKSRC}/configure
.include <bsd.port.mk>