aboutsummaryrefslogtreecommitdiff
path: root/math/brial/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-03-31 17:28:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-03-31 17:28:25 +0000
commitc69dbae5173945fb98ca24e76315d10dd4e29c77 (patch)
tree453544e3c90b9fcae133c7d6143f1254e040f593 /math/brial/Makefile
parentdcfae172f209aa0d8b0d959a5f30caeca4a7aec5 (diff)
Adding BRiAl, a library for polynomials over boolean rings, and its Python
module. To be used by SageMath.
Notes
Notes: svn path=/head/; revision=529990
Diffstat (limited to 'math/brial/Makefile')
-rw-r--r--math/brial/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/brial/Makefile b/math/brial/Makefile
new file mode 100644
index 000000000000..d9be534cc054
--- /dev/null
+++ b/math/brial/Makefile
@@ -0,0 +1,28 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= BRiAl
+PORTVERSION= 1.2.8
+CATEGORIES= math
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Library for polynomials over boolean rings
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libm4ri.so:math/m4ri \
+ libgd.so:graphics/gd \
+ libpng.so:graphics/png \
+ libboost_thread.so:devel/boost-libs
+
+USE_GITHUB= yes
+GH_ACCOUNT= BRiAl
+
+USES= autoreconf compiler:c++11-lang libtool localbase pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+TEST_TARGET= check
+
+.include <bsd.port.mk>