aboutsummaryrefslogtreecommitdiff
path: root/math/cadabra2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-07 06:34:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-07 06:34:59 +0000
commit20c2b6f77675415ad3ac2d5b7244368c429f52bf (patch)
tree8a61cf16069bfcebaa822be7062dfd275c651564 /math/cadabra2
parent7bcee445388671c11c01102c1f6ee0bebcc33fe5 (diff)
downloadports-20c2b6f77675415ad3ac2d5b7244368c429f52bf.tar.gz
ports-20c2b6f77675415ad3ac2d5b7244368c429f52bf.zip
Notes
Diffstat (limited to 'math/cadabra2')
-rw-r--r--math/cadabra2/Makefile7
-rw-r--r--math/cadabra2/distinfo6
-rw-r--r--math/cadabra2/files/patch-client__server_CMakeLists.txt55
-rw-r--r--math/cadabra2/files/patch-client__server_Server.cc11
-rw-r--r--math/cadabra2/files/patch-cmake_version.cmake18
-rw-r--r--math/cadabra2/files/patch-core_CMakeLists.txt47
-rw-r--r--math/cadabra2/files/patch-frontend_gtkmm_CMakeLists.txt42
-rw-r--r--math/cadabra2/files/patch-pybind11-libc++726
-rw-r--r--math/cadabra2/pkg-plist15
9 files changed, 94 insertions, 133 deletions
diff --git a/math/cadabra2/Makefile b/math/cadabra2/Makefile
index 449c1af6f6cb..19aa2eaed582 100644
--- a/math/cadabra2/Makefile
+++ b/math/cadabra2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cadabra2
-DISTVERSION= 2.2.0
-PORTREVISION= 3
+DISTVERSION= 2.2.2
CATEGORIES= math
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -24,7 +23,7 @@ LIB_DEPENDS= ${PY_BOOST} \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sympy/__init__.py:math/py-sympy@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR}
-USES= compiler:c++14-lang cmake:outsource dos2unix gettext-runtime localbase:ldflags pkgconfig python:3.4+ sqlite # USES=python picks random python versions
+USES= compiler:c++14-lang cmake:outsource dos2unix gettext-runtime gnome localbase:ldflags pkgconfig python:3.4+ sqlite # USES=python picks random python versions
USE_GITHUB= yes
GH_ACCOUNT= kpeeters
DOS2UNIX_FILES= cmake/version.cmake
@@ -33,7 +32,7 @@ USE_TEX= base texmf texhash
USE_LDCONFIG= yes
OPTIONS_SUB= yes
-CMAKE_ON= USE_PYTHON_3 # OFF doesn't work, still links to python3: https://github.com/kpeeters/cadabra2/issues/76
+CMAKE_ON= BUILD_SHARED_LIBS USE_PYTHON_3 # OFF doesn't work, still links to python3: https://github.com/kpeeters/cadabra2/issues/76
CMAKE_OFF= ENABLE_MATHEMATICA
CXXFLAGS+= -I${LOCALBASE}/include/jsoncpp
LDFLAGS+= -ljsoncpp
diff --git a/math/cadabra2/distinfo b/math/cadabra2/distinfo
index 8ea142c71f34..571d501f9ea6 100644
--- a/math/cadabra2/distinfo
+++ b/math/cadabra2/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1522534466
-SHA256 (kpeeters-cadabra2-2.2.0_GH0.tar.gz) = 4e0a408ab8fa611091bc4d776dd44efd730c2651e02e62cfd0251bd1d6b96249
-SIZE (kpeeters-cadabra2-2.2.0_GH0.tar.gz) = 23915602
+TIMESTAMP = 1544157018
+SHA256 (kpeeters-cadabra2-2.2.2_GH0.tar.gz) = 9245ceb5b5b3901709060364356bb6db2f6d2d3c7f03f51f9a0ee7d239e15351
+SIZE (kpeeters-cadabra2-2.2.2_GH0.tar.gz) = 23979382
SHA256 (5d52108df5b05eeba2ffbd7220776887297c2846.patch) = 91c1259345332b9fc4b52eafa1c510d2a851b99ca708fa25af5673cdf737be87
SIZE (5d52108df5b05eeba2ffbd7220776887297c2846.patch) = 735
diff --git a/math/cadabra2/files/patch-client__server_CMakeLists.txt b/math/cadabra2/files/patch-client__server_CMakeLists.txt
index 5eb0b54f9437..0ddba45234f5 100644
--- a/math/cadabra2/files/patch-client__server_CMakeLists.txt
+++ b/math/cadabra2/files/patch-client__server_CMakeLists.txt
@@ -1,35 +1,26 @@
---- client_server/CMakeLists.txt.orig 2018-03-30 09:33:27 UTC
+--- client_server/CMakeLists.txt.orig 2018-12-07 04:46:45 UTC
+++ client_server/CMakeLists.txt
-@@ -28,7 +28,6 @@ find_package(Boost 1.53.0 COMPONENTS sys
- set(CADABRA_SERVER_SRC
- Server.cc
- Snoop.cc
-- jsoncpp/jsoncpp.cpp
- ../core/CdbPython.cc
- ../core/Stopwatch.cc
- ../core/ProgressMonitor.cc
+@@ -32,7 +32,6 @@ set(CADABRA_SERVER_SRC
+ ${CADABRA_CORE_DIR}/InstallPrefix.cc
+ ${CADABRA_CORE_DIR}/CdbPython.cc
+ ${CADABRA_CORE_DIR}/Stopwatch.cc
+- ${CADABRA_LIBS_DIR}/jsoncpp/jsoncpp.cpp
+ ${CADABRA_LIBS_DIR}/whereami/whereami.c
+ )
+
@@ -43,7 +42,6 @@ set(CADABRA_CLIENT_SRC
- ../core/DataCell.cc
- Actions.cc
- Snoop.cc
-- jsoncpp/jsoncpp.cpp
- ../libs/whereami/whereami.c
- ../core/InstallPrefix.cc
- # ../libs/sqlite3/sqlite3.c
-@@ -58,7 +56,6 @@ include_directories(
- "../core"
- "../libs/pybind11/include"
- "websocketpp"
-- "jsoncpp"
- "../libs/internal/include"
- "../libs/whereami"
- ${Boost_INCLUDE_DIRS}
-@@ -114,7 +111,7 @@ add_executable(cadabra2html cadabra2html
- target_link_libraries(cadabra2html cadabra_client)
+ Snoop.cc
+ ${CADABRA_CORE_DIR}/DataCell.cc
+ ${CADABRA_CORE_DIR}/InstallPrefix.cc
+- ${CADABRA_LIBS_DIR}/jsoncpp/jsoncpp.cpp
+ ${CADABRA_LIBS_DIR}/whereami/whereami.c
+ )
- # Client library
--add_library(cadabra_client STATIC ${CADABRA_CLIENT_SRC})
-+add_library(cadabra_client SHARED ${CADABRA_CLIENT_SRC})
- target_link_libraries(cadabra_client
- ${Boost_LIBRARIES}
- ${SQLITE3_LIBRARIES}
+@@ -56,7 +54,6 @@ include_directories(
+ "${CADABRA_CORE_DIR}"
+ "${CADABRA_LIBS_DIR}/pybind11/include"
+ "${CADABRA_LIBS_DIR}/websocketpp"
+- "${CADABRA_LIBS_DIR}/jsoncpp"
+ "${CADABRA_LIBS_DIR}/internal/include"
+ "${CADABRA_LIBS_DIR}/whereami"
+ ${Boost_INCLUDE_DIRS}
diff --git a/math/cadabra2/files/patch-client__server_Server.cc b/math/cadabra2/files/patch-client__server_Server.cc
deleted file mode 100644
index 8484130502ff..000000000000
--- a/math/cadabra2/files/patch-client__server_Server.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- client_server/Server.cc.orig 2018-03-31 19:40:16 UTC
-+++ client_server/Server.cc
-@@ -466,7 +466,7 @@ void Server::run()
-
- wserver.init_asio();
- wserver.set_reuse_addr(true);
-- wserver.listen(0);
-+ wserver.listen(websocketpp::lib::asio::ip::tcp::v4(), 0); // makes up for a failed assumption that IPv6 is mapped into IPv4: (see net.inet6.ip6.v6only=0)
- wserver.start_accept();
- websocketpp::lib::asio::error_code ec;
- auto p = wserver.get_local_endpoint(ec);
diff --git a/math/cadabra2/files/patch-cmake_version.cmake b/math/cadabra2/files/patch-cmake_version.cmake
index 058e3e7331e4..70cbec0ab740 100644
--- a/math/cadabra2/files/patch-cmake_version.cmake
+++ b/math/cadabra2/files/patch-cmake_version.cmake
@@ -1,15 +1,15 @@
---- cmake/version.cmake.orig 2018-03-31 20:48:09 UTC
+--- cmake/version.cmake.orig 2018-12-07 05:19:36 UTC
+++ cmake/version.cmake
-@@ -3,13 +3,13 @@ set(CADABRA_VERSION_MINOR 2)
- set(CADABRA_VERSION_PATCH 0)
+@@ -4,7 +4,7 @@ set(CADABRA_VERSION_PATCH 2)
set(CADABRA_VERSION_TWEAK 0)
set(COPYRIGHT_YEARS "2001-2018")
--execute_process(COMMAND git rev-parse --short HEAD OUTPUT_VARIABLE GIT_SHORT_SHA OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND git rev-list --count HEAD OUTPUT_VARIABLE GIT_COMMIT_SERIAL OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND git log -1 --date=short --pretty=format:%cd OUTPUT_VARIABLE GIT_COMMIT_DATE OUTPUT_STRIP_TRAILING_WHITESPACE)
-+#execute_process(COMMAND git rev-parse --short HEAD OUTPUT_VARIABLE GIT_SHORT_SHA OUTPUT_STRIP_TRAILING_WHITESPACE)
-+#execute_process(COMMAND git rev-list --count HEAD OUTPUT_VARIABLE GIT_COMMIT_SERIAL OUTPUT_STRIP_TRAILING_WHITESPACE)
-+#execute_process(COMMAND git log -1 --date=short --pretty=format:%cd OUTPUT_VARIABLE GIT_COMMIT_DATE OUTPUT_STRIP_TRAILING_WHITESPACE)
+ math(EXPR SYSTEM_BITS "${CMAKE_SIZEOF_VOID_P} * 8")
+-find_program(GIT git PATHS ${GIT_DIR})
++#find_program(GIT git PATHS ${GIT_DIR})
+ if(GIT)
+ message("-- Git found: ${GIT}")
+ execute_process(COMMAND git rev-parse --short HEAD OUTPUT_VARIABLE GIT_SHORT_SHA OUTPUT_STRIP_TRAILING_WHITESPACE)
+@@ -16,7 +16,7 @@ endif()
if(GIT_SHORT_SHA)
set(CADABRA_VERSION_BUILD "${GIT_COMMIT_SERIAL}.${GIT_SHORT_SHA}")
else()
diff --git a/math/cadabra2/files/patch-core_CMakeLists.txt b/math/cadabra2/files/patch-core_CMakeLists.txt
index cabacf9a4837..9bcd7e63210f 100644
--- a/math/cadabra2/files/patch-core_CMakeLists.txt
+++ b/math/cadabra2/files/patch-core_CMakeLists.txt
@@ -1,19 +1,34 @@
---- core/CMakeLists.txt.orig 2018-03-31 17:08:45 UTC
+--- core/CMakeLists.txt.orig 2018-12-07 05:20:52 UTC
+++ core/CMakeLists.txt
-@@ -197,7 +197,6 @@ include_directories(
- "."
- "../libs/internal/include"
- "../libs/whereami"
-- "../client_server/jsoncpp"
- ${Boost_INCLUDE_DIRS}
+@@ -204,7 +204,6 @@ set(LOCAL_SRC_FILES
+ modules/xperm_new.cc
+ ${ALGORITHM_SRC_FILES}
+ ${PROPERTY_SRC_FILES}
+- ${CADABRA_LIBS_DIR}/jsoncpp/jsoncpp.cpp
+ )
+ if(MATHEMATICA_FOUND)
+ set(LOCAL_SRC_FILES
+@@ -227,7 +226,6 @@ include_directories(
+ "."
+ "${CADABRA_LIBS_DIR}/internal/include"
+ "${CADABRA_LIBS_DIR}/whereami"
+- "${CADABRA_LIBS_DIR}/jsoncpp"
+ ${Boost_INCLUDE_DIRS}
)
# FIXME: 2nd line is to find Config.hh
-@@ -246,7 +245,7 @@ target_link_libraries(cadabra2python
- )
-
- # cadabra2cadabra
--add_executable(cadabra2cadabra cadabra2cadabra.cc DataCell.cc ../client_server/jsoncpp/jsoncpp.cpp ../libs/whereami/whereami.c InstallPrefix.cc)
-+add_executable(cadabra2cadabra cadabra2cadabra.cc DataCell.cc ../libs/whereami/whereami.c InstallPrefix.cc)
- target_link_libraries(cadabra2cadabra ${Boost_LIBRARIES})
-
- # Mathematica WSTP test
+@@ -263,7 +261,6 @@ add_executable(test_preprocessor
+ add_executable(cadabra2python
+ cadabra2python.cc
+ CdbPython.cc
+- ${CADABRA_LIBS_DIR}/jsoncpp/jsoncpp.cpp
+ )
+ target_link_libraries(cadabra2python
+ ${Boost_LIBRARIES}
+@@ -275,7 +272,6 @@ add_executable(cadabra2cadabra
+ cadabra2cadabra.cc
+ DataCell.cc
+ InstallPrefix.cc
+- ${CADABRA_LIBS_DIR}/jsoncpp/jsoncpp.cpp
+ ${CADABRA_LIBS_DIR}/whereami/whereami.c
+ )
+ target_link_libraries(cadabra2cadabra ${Boost_LIBRARIES} ${GLIBMM3_LIBRARIES})
diff --git a/math/cadabra2/files/patch-frontend_gtkmm_CMakeLists.txt b/math/cadabra2/files/patch-frontend_gtkmm_CMakeLists.txt
index 84d2d10e29f9..f47dd7ecf00d 100644
--- a/math/cadabra2/files/patch-frontend_gtkmm_CMakeLists.txt
+++ b/math/cadabra2/files/patch-frontend_gtkmm_CMakeLists.txt
@@ -1,31 +1,15 @@
---- frontend/gtkmm/CMakeLists.txt.orig 2018-03-30 09:33:27 UTC
+--- frontend/gtkmm/CMakeLists.txt.orig 2018-12-07 05:18:13 UTC
+++ frontend/gtkmm/CMakeLists.txt
-@@ -126,11 +126,11 @@ install(FILES ${PROJECT_SOURCE_DIR}/.
- # there anyway.
- # - gtk-update-icon-cache is broken and only works half of the time.
+@@ -165,9 +165,9 @@ if (NOT INSTALL_TARGETS_ONLY)
+ install(FILES ${CADABRA_IMAGES_DIR}/256x256/cadabra2-gtk.png DESTINATION ${ICON_PREFIX}/share/icons/hicolor/256x256/apps)
+ install(FILES ${CADABRA_IMAGES_DIR}/cadabra2-gtk.svg DESTINATION ${ICON_PREFIX}/share/icons/hicolor/scalable/apps)
+ install(FILES ${CADABRA_ROOT_DIR}/config/cadabra2-gtk.desktop DESTINATION ${ICON_PREFIX}/share/applications)
+- install(CODE "execute_process(COMMAND touch ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
+- install(CODE "execute_process(COMMAND gtk-update-icon-cache-3.0 ${ICON_PREFIX}/share/icons/hicolor)")
+- install(CODE "execute_process(COMMAND chmod go+r ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
++ #install(CODE "execute_process(COMMAND touch ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
++ #install(CODE "execute_process(COMMAND gtk-update-icon-cache-3.0 ${ICON_PREFIX}/share/icons/hicolor)")
++ #install(CODE "execute_process(COMMAND chmod go+r ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
--if(APPLE)
-+#if(APPLE)
- set(ICON_PREFIX "${CMAKE_INSTALL_PREFIX}")
--else()
-- set(ICON_PREFIX "/usr")
--endif()
-+#else()
-+# set(ICON_PREFIX "/usr")
-+#endif()
-
- #set(ICON_THEME ${ICON_PREFIX}/share/icons/hicolor/index.theme)
- #if(EXISTS "${ICON_THEME}")
-@@ -144,9 +144,9 @@ install(FILES ${PROJECT_SOURCE_DIR}/.
- install(FILES ${PROJECT_SOURCE_DIR}/../../images/256x256/cadabra2-gtk.png DESTINATION ${ICON_PREFIX}/share/icons/hicolor/256x256/apps)
- install(FILES ${PROJECT_SOURCE_DIR}/../../images/cadabra2-gtk.svg DESTINATION ${ICON_PREFIX}/share/icons/hicolor/scalable/apps)
- install(FILES ${PROJECT_SOURCE_DIR}/../../config/cadabra2-gtk.desktop DESTINATION ${ICON_PREFIX}/share/applications)
--install(CODE "execute_process(COMMAND touch ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
--install(CODE "execute_process(COMMAND gtk-update-icon-cache-3.0 ${ICON_PREFIX}/share/icons/hicolor)")
--install(CODE "execute_process(COMMAND chmod go+r ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
-+#install(CODE "execute_process(COMMAND touch ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
-+#install(CODE "execute_process(COMMAND gtk-update-icon-cache-3.0 ${ICON_PREFIX}/share/icons/hicolor)")
-+#install(CODE "execute_process(COMMAND chmod go+r ${ICON_PREFIX}/share/icons/hicolor/icon-theme.cache)")
-
- # Install shared libraries on Windows.
- # https://stackoverflow.com/questions/32662215/how-do-you-install-gtk-3-0-on-windows
+ # Install shared libraries on Windows.
+ # https://stackoverflow.com/questions/32662215/how-do-you-install-gtk-3-0-on-windows
diff --git a/math/cadabra2/files/patch-pybind11-libc++7 b/math/cadabra2/files/patch-pybind11-libc++7
deleted file mode 100644
index e41d44dbba0f..000000000000
--- a/math/cadabra2/files/patch-pybind11-libc++7
+++ /dev/null
@@ -1,26 +0,0 @@
-https://github.com/pybind/pybind11/commit/ff6bd092d482b0c4e51aeb7367c3e5ecbc18a9de
-
---- libs/pybind11/include/pybind11/cast.h.orig 2018-03-30 09:33:27 UTC
-+++ libs/pybind11/include/pybind11/cast.h
-@@ -1685,6 +1685,9 @@ template <> inline void cast_safe<void>(object &&) {}
-
- NAMESPACE_END(detail)
-
-+template <return_value_policy policy = return_value_policy::automatic_reference>
-+tuple make_tuple() { return tuple(0); }
-+
- template <return_value_policy policy = return_value_policy::automatic_reference,
- typename... Args> tuple make_tuple(Args&&... args_) {
- constexpr size_t size = sizeof...(Args);
---- libs/pybind11/include/pybind11/stl.h.orig 2018-03-30 09:33:27 UTC
-+++ libs/pybind11/include/pybind11/stl.h
-@@ -30,7 +30,8 @@
- # define PYBIND11_HAS_OPTIONAL 1
- # endif
- // std::experimental::optional (but not allowed in c++11 mode)
--# if defined(PYBIND11_CPP14) && __has_include(<experimental/optional>)
-+# if defined(PYBIND11_CPP14) && (__has_include(<experimental/optional>) && \
-+ !__has_include(<optional>))
- # include <experimental/optional>
- # define PYBIND11_HAS_EXP_OPTIONAL 1
- # endif
diff --git a/math/cadabra2/pkg-plist b/math/cadabra2/pkg-plist
index 5f24c169797a..3bd26f904ef7 100644
--- a/math/cadabra2/pkg-plist
+++ b/math/cadabra2/pkg-plist
@@ -4,21 +4,21 @@ bin/cadabra2
bin/cadabra2cadabra
bin/cadabra2html
bin/cadabra2python
-lib/libcadabra_client.so
+lib/libcadabra_client.a
%%GUI%%share/applications/cadabra2-gtk.desktop
%%GUI%%%%DATADIR%%/images/cadabra2-gtk.png
%%GUI%%%%DATADIR%%/latex/preamble.tex
-%%GUI%%%%DATADIR%%/latex/tableaux.sty
-%%GUI%%@dir %%DATADIR%%/manual/properties
%%GUI%%%%DATADIR%%/manual/algorithms/asym.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/canonicalise.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/collect_factors.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/collect_terms.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/combine.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/complete.cnb
+%%GUI%%%%DATADIR%%/manual/algorithms/decompose.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/decompose_product.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/distribute.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/drop_weight.cnb
+%%GUI%%%%DATADIR%%/manual/algorithms/einsteinify.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/eliminate_kronecker.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/eliminate_metric.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/epsilon_to_delta.cnb
@@ -33,9 +33,11 @@ lib/libcadabra_client.so
%%GUI%%%%DATADIR%%/manual/algorithms/integrate_by_parts.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/join_gamma.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/keep_weight.cnb
+%%GUI%%%%DATADIR%%/manual/algorithms/lower_free_indices.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/lr_tensor.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/map_sympy.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/product_rule.cnb
+%%GUI%%%%DATADIR%%/manual/algorithms/raise_free_indices.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/reduce_delta.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/rename_dummies.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/replace_match.cnb
@@ -52,6 +54,7 @@ lib/libcadabra_client.so
%%GUI%%%%DATADIR%%/manual/algorithms/vary.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/young_project_product.cnb
%%GUI%%%%DATADIR%%/manual/algorithms/young_project_tensor.cnb
+%%GUI%%%%DATADIR%%/manual/algorithms/zoom.cnb
%%GUI%%%%DATADIR%%/manual/properties/Accent.cnb
%%GUI%%%%DATADIR%%/manual/properties/AntiCommuting.cnb
%%GUI%%%%DATADIR%%/manual/properties/AntiSymmetric.cnb
@@ -62,6 +65,7 @@ lib/libcadabra_client.so
%%GUI%%%%DATADIR%%/manual/properties/DAntiSymmetric.cnb
%%GUI%%%%DATADIR%%/manual/properties/Depends.cnb
%%GUI%%%%DATADIR%%/manual/properties/Derivative.cnb
+%%GUI%%%%DATADIR%%/manual/properties/Determinant.cnb
%%GUI%%%%DATADIR%%/manual/properties/Diagonal.cnb
%%GUI%%%%DATADIR%%/manual/properties/DiracBar.cnb
%%GUI%%%%DATADIR%%/manual/properties/Distributable.cnb
@@ -94,10 +98,15 @@ lib/libcadabra_client.so
%%GUI%%%%DATADIR%%/notebook.tex
%%DATADIR%%/python/cadabra2.so
%%DATADIR%%/python/cadabra2_defaults.py
+%%DATADIR%%/python/cdb/core/component.cnb
+%%DATADIR%%/python/cdb/core/manip.cnb
+%%DATADIR%%/python/cdb/core/solve.cnb
%%DATADIR%%/python/cdb/gauge_theory/__init__.py
%%DATADIR%%/python/cdb/gauge_theory/instantons.py
%%DATADIR%%/python/cdb/relativity/__init__.py
%%DATADIR%%/python/cdb/relativity/schwarzschild.py
+%%DATADIR%%/python/cdb/utils/node.cnb
+%%DATADIR%%/python/cdb_appdirs.py
%%GUI%%share/icons/hicolor/128x128/apps/cadabra2-gtk.png
%%GUI%%share/icons/hicolor/256x256/apps/cadabra2-gtk.png
%%GUI%%share/icons/hicolor/64x64/apps/cadabra2-gtk.png