aboutsummaryrefslogtreecommitdiff
path: root/math/cadabra2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-08-08 12:32:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-08-08 12:32:03 +0000
commitd6707e992311ab2418c6e525d6c4136ae64a075c (patch)
tree2e509d92c928944b9c80299d046a2a8f8d22f525 /math/cadabra2
parent348bfa1c8c2404663f2431db9e480e00ed01c5c3 (diff)
downloadports-d6707e992311ab2418c6e525d6c4136ae64a075c.tar.gz
ports-d6707e992311ab2418c6e525d6c4136ae64a075c.zip
Notes
Diffstat (limited to 'math/cadabra2')
-rw-r--r--math/cadabra2/Makefile2
-rw-r--r--math/cadabra2/files/patch-pybind11-libc++726
2 files changed, 27 insertions, 1 deletions
diff --git a/math/cadabra2/Makefile b/math/cadabra2/Makefile
index 74d02eda20b5..bdb60e579181 100644
--- a/math/cadabra2/Makefile
+++ b/math/cadabra2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cadabra2
DISTVERSION= 2.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
diff --git a/math/cadabra2/files/patch-pybind11-libc++7 b/math/cadabra2/files/patch-pybind11-libc++7
new file mode 100644
index 000000000000..e41d44dbba0f
--- /dev/null
+++ b/math/cadabra2/files/patch-pybind11-libc++7
@@ -0,0 +1,26 @@
+https://github.com/pybind/pybind11/commit/ff6bd092d482b0c4e51aeb7367c3e5ecbc18a9de
+
+--- libs/pybind11/include/pybind11/cast.h.orig 2018-03-30 09:33:27 UTC
++++ libs/pybind11/include/pybind11/cast.h
+@@ -1685,6 +1685,9 @@ template <> inline void cast_safe<void>(object &&) {}
+
+ NAMESPACE_END(detail)
+
++template <return_value_policy policy = return_value_policy::automatic_reference>
++tuple make_tuple() { return tuple(0); }
++
+ template <return_value_policy policy = return_value_policy::automatic_reference,
+ typename... Args> tuple make_tuple(Args&&... args_) {
+ constexpr size_t size = sizeof...(Args);
+--- libs/pybind11/include/pybind11/stl.h.orig 2018-03-30 09:33:27 UTC
++++ libs/pybind11/include/pybind11/stl.h
+@@ -30,7 +30,8 @@
+ # define PYBIND11_HAS_OPTIONAL 1
+ # endif
+ // std::experimental::optional (but not allowed in c++11 mode)
+-# if defined(PYBIND11_CPP14) && __has_include(<experimental/optional>)
++# if defined(PYBIND11_CPP14) && (__has_include(<experimental/optional>) && \
++ !__has_include(<optional>))
+ # include <experimental/optional>
+ # define PYBIND11_HAS_EXP_OPTIONAL 1
+ # endif