aboutsummaryrefslogtreecommitdiff
path: root/math/calctool
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-03-09 18:25:08 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-03-09 18:25:08 +0000
commit9ba7436d594036db33a653ba8f5c3a35e14a7d2d (patch)
tree874a397adfa7d1bf2231d12c6a25d7ff599e4184 /math/calctool
parent394b6b3d6a3f0dcc937cf977009039faeec7eaa9 (diff)
downloadports-9ba7436d594036db33a653ba8f5c3a35e14a7d2d.tar.gz
ports-9ba7436d594036db33a653ba8f5c3a35e14a7d2d.zip
Notes
Diffstat (limited to 'math/calctool')
-rw-r--r--math/calctool/Makefile2
-rw-r--r--math/calctool/files/patch-ab34
2 files changed, 20 insertions, 16 deletions
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index efbafc5275b3..f06005832be8 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -17,4 +17,6 @@ MAINTAINER= nsayer@freebsd.org
USE_X_PREFIX= yes
MAN1= calctool.1
+ALL_TARGET= x11
+
.include <bsd.port.mk>
diff --git a/math/calctool/files/patch-ab b/math/calctool/files/patch-ab
index 1b6f64e338e4..fd22b93a54cd 100644
--- a/math/calctool/files/patch-ab
+++ b/math/calctool/files/patch-ab
@@ -1,17 +1,17 @@
---- Makefile.orig Sat May 29 11:35:43 1993
-+++ Makefile Sun Aug 16 10:37:31 1998
+--- Makefile.orig Sat May 29 09:35:43 1993
++++ Makefile Fri Mar 9 10:17:33 2001
@@ -116,8 +116,8 @@
# library files are not in a standard place, then the following
# two lines should be uncommented, and set appropriately.
#
-#X11INCDIR = -I$(OPENWINHOME)/include
-#X11LIBDIR = -L$(OPENWINHOME)/lib
-+X11INCDIR = -I/usr/X11R6/include
-+X11LIBDIR = -L/usr/X11R6/lib
++X11INCDIR = -I${X11BASE}/include
++X11LIBDIR = -L${X11BASE}/lib
#-------------------------------------------------------------------------
# If you are compiling the XView version, then the following two lines
# should be uncommented.
-@@ -130,10 +130,10 @@
+@@ -130,14 +130,14 @@
# Default locations where calctool files will be installed.
# You might wish to alter these values.
#
@@ -26,19 +26,21 @@
#
# Compilation flags and standard macro definitions.
#
-@@ -144,8 +144,9 @@
- #
- #=========================================================================
-
--BINARIES = mgr_calctool ps_calctool sv_calctool \
-- tty_calctool xcalctool xv_calctool
-+#BINARIES = mgr_calctool ps_calctool sv_calctool \
-+# tty_calctool xcalctool xv_calctool
-+BINARIES = x11
+-CFLAGS = -g $(HELPNAME) $(NEWSFILE) $(STUPID_FPE) $(NOIEEE) \
++CFLAGS += $(HELPNAME) $(NEWSFILE) $(STUPID_FPE) $(NOIEEE) \
+ $(NOINDEX) $(RCNAME) $(SELTYPE) $(SHLIB) $(SIGRET) \
+ $(SUN4_KEYBOARD) $(TTEXT) $(MGRPARAM) $(MGRINCDIR) \
+ $(X11INCDIR) $(XVIEWINCDIR)
+@@ -147,7 +147,7 @@
+ BINARIES = mgr_calctool ps_calctool sv_calctool \
+ tty_calctool xcalctool xv_calctool
- CC = cc
+-CC = cc
++#CC = cc
-@@ -233,8 +234,7 @@
+ LIBSRCS = graphics.c display.c functions.c get.c
+ LIBOBJS = graphics.o display.o functions.o get.o
+@@ -233,8 +233,7 @@
ld -o libcalctool.so.1.1 -assert pure-text $?
install: