aboutsummaryrefslogtreecommitdiff
path: root/math/cantor
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-12-11 19:18:03 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-12-11 19:18:03 +0000
commit581c73f04f97d6762abd435c4b72e3f8e8c550fd (patch)
tree0dc336af64336aec1a9efcf64ff6bd6e0da0883d /math/cantor
parentc4efae9bc9605eeefeeafc0384e548ec4cb5d18a (diff)
downloadports-581c73f04f97d6762abd435c4b72e3f8e8c550fd.tar.gz
ports-581c73f04f97d6762abd435c4b72e3f8e8c550fd.zip
Notes
Diffstat (limited to 'math/cantor')
-rw-r--r--math/cantor/Makefile4
-rw-r--r--math/cantor/distinfo6
-rw-r--r--math/cantor/files/patch-cmake_FindPythonLibs3.cmake18
-rw-r--r--math/cantor/pkg-plist26
4 files changed, 20 insertions, 34 deletions
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index abfefd909098..e22636f798af 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -1,5 +1,7 @@
# $FreeBSD$
+# TODO: ensure only ${PYTON_CMD} is pixked again
+
PORTNAME= cantor
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
CATEGORIES= math kde kde-applications
@@ -58,7 +60,5 @@ CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_PythonLibs
post-patch:
${REINPLACE_CMD} -e '/FIND_PROGRAM(_GFORTRAN_EXECUTABLE/s,gfortran,${FC},' \
${WRKSRC}/cmake/FindR.cmake
- ${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' \
- ${WRKSRC}/cmake/FindPythonLibs3.cmake
.include <bsd.port.mk>
diff --git a/math/cantor/distinfo b/math/cantor/distinfo
index ac41cbe4d095..6db7bed07f49 100644
--- a/math/cantor/distinfo
+++ b/math/cantor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604419968
-SHA256 (KDE/release-service/20.08.3/cantor-20.08.3.tar.xz) = 14aefe60ca2ff7aeaf7af8080dd00e80be8d747faeb9cd5a2df88f0d3af358da
-SIZE (KDE/release-service/20.08.3/cantor-20.08.3.tar.xz) = 9082332
+TIMESTAMP = 1607111073
+SHA256 (KDE/release-service/20.12.0/cantor-20.12.0.tar.xz) = d8fd85639c86d7cd1826f1278b913c1aa45f4e4fd9eff6890441d5de3578a5aa
+SIZE (KDE/release-service/20.12.0/cantor-20.12.0.tar.xz) = 9102652
diff --git a/math/cantor/files/patch-cmake_FindPythonLibs3.cmake b/math/cantor/files/patch-cmake_FindPythonLibs3.cmake
deleted file mode 100644
index 5eade9aaaf40..000000000000
--- a/math/cantor/files/patch-cmake_FindPythonLibs3.cmake
+++ /dev/null
@@ -1,18 +0,0 @@
---- cmake/FindPythonLibs3.cmake.orig 2020-10-31 16:59:49 UTC
-+++ cmake/FindPythonLibs3.cmake
-@@ -1,5 +1,5 @@
- find_package(PkgConfig)
--pkg_check_modules(PYTHONLIBS3 QUIET python3)
-+pkg_check_modules(PYTHONLIBS3 QUIET python-%%PYTHON_VER%%)
- set(PYTHONLIBS3_DEFINITIONS ${PYTHONLIBS3_CFLAGS_OTHER})
-
- find_path(PYTHONLIBS3_INCLUDE_DIR Python.h
-@@ -9,7 +9,7 @@ IF(WIN32)
- find_library(PYTHONLIBS3_LIBRARY NAMES python32 python33 python34 python35 python36 python37 python38
- HINTS ${PYTHONLIBS3_LIBDIR} ${PYTHONLIBS3_LIBRARY_DIRS} )
- ELSE()
-- find_library(PYTHONLIBS3_LIBRARY NAMES python3.2m python3.3m python3.4m python3.5m python3.6m python3.7m python3.8
-+ find_library(PYTHONLIBS3_LIBRARY NAMES python%%PYTHON_VER%% python3.7 python3.2m python3.3m python3.4m python3.5m python3.6m python3.7m python3.8
- HINTS ${PYTHONLIBS3_LIBDIR} ${PYTHONLIBS3_LIBRARY_DIRS} )
- ENDIF()
-
diff --git a/math/cantor/pkg-plist b/math/cantor/pkg-plist
index 340b05b978be..71aedf77fbee 100644
--- a/math/cantor/pkg-plist
+++ b/math/cantor/pkg-plist
@@ -2,16 +2,6 @@ bin/cantor
bin/cantor_pythonserver
%%R%%bin/cantor_rserver
bin/cantor_scripteditor
-etc/xdg/cantor.knsrc
-etc/xdg/cantor_kalgebra.knsrc
-%%LUAJIT%%etc/xdg/cantor_lua.knsrc
-etc/xdg/cantor_maxima.knsrc
-etc/xdg/cantor_octave.knsrc
-etc/xdg/cantor_python.knsrc
-etc/xdg/cantor_qalculate.knsrc
-%%R%%etc/xdg/cantor_r.knsrc
-etc/xdg/cantor_sage.knsrc
-etc/xdg/cantor_scilab.knsrc
include/cantor/animationresult.h
include/cantor/backend.h
include/cantor/cantor_export.h
@@ -30,6 +20,8 @@ include/cantor/imageresult.h
include/cantor/jupyterutils.h
include/cantor/latexresult.h
include/cantor/mimeresult.h
+include/cantor/panelplugin.h
+include/cantor/panelpluginhandler.h
include/cantor/renderer.h
include/cantor/result.h
include/cantor/session.h
@@ -43,7 +35,7 @@ lib/cmake/Cantor/CantorTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Cantor/CantorTargets.cmake
lib/libcantor_config.so
lib/libcantorlibs.so
-lib/libcantorlibs.so.27
+lib/libcantorlibs.so.28
lib/libcantorlibs.so.%%KDE_APPLICATIONS_VERSION%%
%%QT_PLUGINDIR%%/cantor/assistants/cantor_advancedplotassistant.so
%%QT_PLUGINDIR%%/cantor/assistants/cantor_creatematrixassistant.so
@@ -69,6 +61,7 @@ lib/libcantorlibs.so.%%KDE_APPLICATIONS_VERSION%%
%%QT_PLUGINDIR%%/cantor/backends/cantor_scilabbackend.so
%%QT_PLUGINDIR%%/cantor/panels/cantor_filebrowserpanelplugin.so
%%QT_PLUGINDIR%%/cantor/panels/cantor_helppanelplugin.so
+%%QT_PLUGINDIR%%/cantor/panels/cantor_tocpanelplugin.so
%%QT_PLUGINDIR%%/cantor/panels/cantor_variablemanagerplugin.so
%%QT_PLUGINDIR%%/libcantorpart.so
share/applications/org.kde.cantor.desktop
@@ -109,6 +102,16 @@ share/icons/hicolor/48x48/apps/rbackend.png
share/icons/hicolor/48x48/apps/sagebackend.png
share/icons/hicolor/48x48/apps/scilabbackend.png
share/icons/hicolor/64x64/apps/cantor.png
+share/knsrcfiles/cantor.knsrc
+share/knsrcfiles/cantor_kalgebra.knsrc
+%%LUAJIT%%share/knsrcfiles/cantor_lua.knsrc
+share/knsrcfiles/cantor_maxima.knsrc
+share/knsrcfiles/cantor_octave.knsrc
+share/knsrcfiles/cantor_python.knsrc
+share/knsrcfiles/cantor_qalculate.knsrc
+%%R%%share/knsrcfiles/cantor_r.knsrc
+share/knsrcfiles/cantor_sage.knsrc
+share/knsrcfiles/cantor_scilab.knsrc
share/kxmlgui5/cantor/cantor_advancedplot_assistant.rc
share/kxmlgui5/cantor/cantor_create_matrix_assistant.rc
share/kxmlgui5/cantor/cantor_differentiate_assistant.rc
@@ -143,6 +146,7 @@ share/locale/ga/LC_MESSAGES/cantor.mo
share/locale/gl/LC_MESSAGES/cantor.mo
share/locale/hr/LC_MESSAGES/cantor.mo
share/locale/hu/LC_MESSAGES/cantor.mo
+share/locale/ia/LC_MESSAGES/cantor.mo
share/locale/it/LC_MESSAGES/cantor.mo
share/locale/ja/LC_MESSAGES/cantor.mo
share/locale/kk/LC_MESSAGES/cantor.mo