aboutsummaryrefslogtreecommitdiff
path: root/math/ccmath
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-03-20 18:25:10 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-03-20 18:25:10 +0000
commitd086d86d5014bd73758935d3a4aa7e6b536c34a1 (patch)
tree40f505b28ed224ae18fa8c213ffa7c51c936964a /math/ccmath
parentce453a0274b38fca50344dba09f5c67aa170e393 (diff)
downloadports-d086d86d5014bd73758935d3a4aa7e6b536c34a1.tar.gz
ports-d086d86d5014bd73758935d3a4aa7e6b536c34a1.zip
Add ccmath, a mathematics library with many functions.
PR: 25589 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Notes
Notes: svn path=/head/; revision=40118
Diffstat (limited to 'math/ccmath')
-rw-r--r--math/ccmath/Makefile35
-rw-r--r--math/ccmath/distinfo1
-rw-r--r--math/ccmath/files/patch-aa14
-rw-r--r--math/ccmath/files/patch-ab11
-rw-r--r--math/ccmath/files/patch-ac30
-rw-r--r--math/ccmath/pkg-comment1
-rw-r--r--math/ccmath/pkg-descr8
-rw-r--r--math/ccmath/pkg-plist19
8 files changed, 119 insertions, 0 deletions
diff --git a/math/ccmath/Makefile b/math/ccmath/Makefile
new file mode 100644
index 000000000000..77ad7ca65dcc
--- /dev/null
+++ b/math/ccmath/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ccmath
+# Date created: 07 March 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccmath
+PORTVERSION= 2.2.0
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= libs
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+INSTALLS_SHLIB= yes
+
+post-configure:
+.if (${MACHINE_ARCH} != "i386")
+ (cd ${WRKSRC} && ${SH} non_intel.sh)
+.endif
+
+do-build:
+ (cd ${WRKSRC} && ${SH} makelibs.sh)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/ccmath.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/tmp/libccm.a ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/tmp/libccm.so ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ccmath
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${PREFIX}/share/doc/ccmath
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ccmath/distinfo b/math/ccmath/distinfo
new file mode 100644
index 000000000000..0125fafdb9a9
--- /dev/null
+++ b/math/ccmath/distinfo
@@ -0,0 +1 @@
+MD5 (ccmath-2.2.0.tar.gz) = 96d9b148d4dc06dba82441006b39a3d3
diff --git a/math/ccmath/files/patch-aa b/math/ccmath/files/patch-aa
new file mode 100644
index 000000000000..5094b1058252
--- /dev/null
+++ b/math/ccmath/files/patch-aa
@@ -0,0 +1,14 @@
+--- non_intel.sh.orig Wed Mar 7 16:13:59 2001
++++ non_intel.sh Wed Mar 7 16:14:20 2001
+@@ -13,9 +13,5 @@
+ rm $MDR/simu/*.s
+ echo " .s code replaced in simu"
+ echo
+-echo " bigendian byte order (y/n)"
+-read F
+-if [ $F = "y" ]
+- then cp $MDR/xarm/supp/big-end/*.c $MDR/xarm
+- echo " bigend code installed in xarm"
+-fi
++cp $MDR/xarm/supp/big-end/*.c $MDR/xarm
++echo " bigend code installed in xarm"
diff --git a/math/ccmath/files/patch-ab b/math/ccmath/files/patch-ab
new file mode 100644
index 000000000000..c386e839fff6
--- /dev/null
+++ b/math/ccmath/files/patch-ab
@@ -0,0 +1,11 @@
+--- tseries/sany.c.orig Wed Mar 7 16:20:33 2001
++++ tseries/sany.c Wed Mar 7 16:20:40 2001
+@@ -5,7 +5,7 @@
+ * public license (LGPL). ( See the lgpl.license file for details.)
+ * ------------------------------------------------------------------------
+ */
+-#include "ccmath.h"
++#include "../ccmath.h"
+ int sany(double *x,int n,double *pm,double *cd,double *ci,
+ int nd,int ms,int lag)
+ { struct complex *pc,*p,**qc,**q;
diff --git a/math/ccmath/files/patch-ac b/math/ccmath/files/patch-ac
new file mode 100644
index 000000000000..707f54041035
--- /dev/null
+++ b/math/ccmath/files/patch-ac
@@ -0,0 +1,30 @@
+--- makelibs.sh.orig Wed Mar 7 16:18:01 2001
++++ makelibs.sh Wed Mar 7 16:18:36 2001
+@@ -9,23 +9,19 @@
+ LST="cfit complex fft geom intg matrix roots sfunc simu sort statf tseries util xarm"
+ MDR=`pwd`
+ LSOD=$MDR/tmp
+-echo "Intel platform ? (y/n)"
+-read F
+ for dr in $LST
+ do
+ cd $MDR/$dr
+ echo `pwd`
+- cc -c -O3 *.c
++ cc -c $CFLAGS *.c
+ mv *.o $LSOD
+ done
+-if [ $F = "y" ]
+- then cd $MDR/matrix
+- cc -c -O3 solv.s
++ cd $MDR/matrix
++ cc -c $CFLAGS solv.s
+ mv *.o $LSOD
+ cd $MDR/simu
+- cc -c -O3 *.s
++ cc -c $CFLAGS *.s
+ mv *.o $LSOD
+-fi
+ cd $LSOD
+ ar r libccm.a *.o
+ ld -shared -o libccm.so *.o
diff --git a/math/ccmath/pkg-comment b/math/ccmath/pkg-comment
new file mode 100644
index 000000000000..774c011f0284
--- /dev/null
+++ b/math/ccmath/pkg-comment
@@ -0,0 +1 @@
+A mathematics library with many different functions
diff --git a/math/ccmath/pkg-descr b/math/ccmath/pkg-descr
new file mode 100644
index 000000000000..af9513de3f18
--- /dev/null
+++ b/math/ccmath/pkg-descr
@@ -0,0 +1,8 @@
+CCMATH is a mathematics library, coded in C, that contains functions
+for linear algebra, numerical integration, geometry and trigonometry,
+curve fitting, roots and optimization, Fourier analysis, simulation
+generation, statistics, special functions, sorts and searches, time
+series models, complex arithmetic, and high precision computations.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/math/ccmath/pkg-plist b/math/ccmath/pkg-plist
new file mode 100644
index 000000000000..e017b0d2e56b
--- /dev/null
+++ b/math/ccmath/pkg-plist
@@ -0,0 +1,19 @@
+include/ccmath.h
+lib/libccm.a
+lib/libccm.so
+%%PORTDOCS%%share/doc/ccmath/C00-intro
+%%PORTDOCS%%share/doc/ccmath/C01-matrix
+%%PORTDOCS%%share/doc/ccmath/C02-intg
+%%PORTDOCS%%share/doc/ccmath/C03-geom
+%%PORTDOCS%%share/doc/ccmath/C04-cfit
+%%PORTDOCS%%share/doc/ccmath/C05-roots
+%%PORTDOCS%%share/doc/ccmath/C06-fft
+%%PORTDOCS%%share/doc/ccmath/C07-simu
+%%PORTDOCS%%share/doc/ccmath/C08-statf
+%%PORTDOCS%%share/doc/ccmath/C09-sfunc
+%%PORTDOCS%%share/doc/ccmath/C10-sort
+%%PORTDOCS%%share/doc/ccmath/C11-tseries
+%%PORTDOCS%%share/doc/ccmath/C12-complex
+%%PORTDOCS%%share/doc/ccmath/C13-xarm
+%%PORTDOCS%%share/doc/ccmath/C14-util
+%%PORTDOCS%%@dirrm share/doc/ccmath