aboutsummaryrefslogtreecommitdiff
path: root/math/ccmath
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-06-25 00:29:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-06-25 00:29:09 +0000
commit45cb752a04894d48090981be1a7d2f549f2b684f (patch)
treeec081b06d4ac1171d90c17f7c227c9b2007dc591 /math/ccmath
parent5b72408838c185b3a8f6d14cd522ed27f7fd4ed2 (diff)
Begin deorbit burn of ia64. We have not attempted to build packages for
it for many years. While here, alphabetize ARCHs, pet portlint, and modernize usages. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=444251
Diffstat (limited to 'math/ccmath')
-rw-r--r--math/ccmath/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/ccmath/Makefile b/math/ccmath/Makefile
index d9cf7e3a045c..5d1f8c07bd27 100644
--- a/math/ccmath/Makefile
+++ b/math/ccmath/Makefile
@@ -20,7 +20,7 @@ SRC_DIRS= cfit complex fft geom intg matrix roots sfunc simu sort statf \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+.if ${ARCH} == "amd64"
COPT= -fPIC
.endif
@@ -44,11 +44,11 @@ do-build:
${CC} -shared -Wl,-soname=libccm.so.1 -o libccm.so.1 *.o)
do-install:
- @${INSTALL_DATA} ${WRKSRC}/ccmath.h ${STAGEDIR}${PREFIX}/include
- @${INSTALL_DATA} ${WRKSRC}/tmp/libccm.a ${STAGEDIR}${PREFIX}/lib
- @${INSTALL_LIB} ${WRKSRC}/tmp/libccm.so.1 ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/ccmath.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/tmp/libccm.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/tmp/libccm.so.1 ${STAGEDIR}${PREFIX}/lib
@${LN} -s libccm.so.1 ${STAGEDIR}${PREFIX}/lib/libccm.so
@${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/ccmath
- @${INSTALL_DATA} ${WRKSRC}/manual/* ${STAGEDIR}${PREFIX}/share/doc/ccmath
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${STAGEDIR}${PREFIX}/share/doc/ccmath
.include <bsd.port.post.mk>