aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-01 13:42:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-01 13:42:54 +0000
commit9d1dc2407c8c73dc5926948037e09b3d55402ec2 (patch)
tree38db9f1d8ee32af4ab5c52ef2f7c2b9aef2a174d /math/ceres-solver/Makefile
parent703d0747022749b4474a5ea5bda11e2ee9768aec (diff)
downloadports-9d1dc2407c8c73dc5926948037e09b3d55402ec2.tar.gz
ports-9d1dc2407c8c73dc5926948037e09b3d55402ec2.zip
Notes
Diffstat (limited to 'math/ceres-solver/Makefile')
-rw-r--r--math/ceres-solver/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 5c1500585a41..9c8909e64d17 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -23,7 +23,7 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
scripts/make_docs.py
-CMAKE_ARGS= -DCXX11=on -DBUILD_SHARED_LIBS=on
+CMAKE_ON= CXX11 BUILD_SHARED_LIBS
LDFLAGS+= -Wl,--as-needed # -lccolamd -lcholmod -lrt from suitesparse
PLIST_SUB= VERSION=${DISTVERSION:C/rc.*//}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:S/-solver//}
@@ -67,26 +67,27 @@ TEST_IMPLIES= GFLAGS
LAPACK_DESC= Linear Algebra PACKage
LAPACK_USES= fortran # LDFLAGS
-LAPACK_CMAKE_ON= -DBLAS_LIBRARIES="${BLASLIB}" -DLAPACK_LIBRARIES="${LAPACKLIB}"
+LAPACK_CMAKE_ON= -DBLAS_LIBRARIES:FILEPATH="${BLASLIB}" \
+ -DLAPACK_LIBRARIES:FILEPATH="${LAPACKLIB}"
LAPACK_CMAKE_BOOL= LAPACK
ATLAS_USES= blaslapack:atlas
-ATLAS_CMAKE_ON= -DBLA_VENDOR="ATLAS"
+ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS"
ATLAS_IMPLIES= LAPACK
GOTOBLAS_DESC= Goto blas implementation
GOTOBLAS_USES= blaslapack:gotoblas
-GOTOBLAS_CMAKE_ON= -DBLA_VENDOR="Goto"
+GOTOBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="Goto"
GOTOBLAS_IMPLIES= LAPACK
NETLIB_USES= blaslapack:netlib
-NETLIB_CMAKE_ON= -DBLA_VENDOR="Generic"
+NETLIB_CMAKE_ON= -DBLA_VENDOR:STRING="Generic"
NETLIB_IMPLIES= LAPACK
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_CMAKE_ON= -DBLA_VENDOR="OpenBLAS"
+OPENBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="OpenBLAS"
OPENBLAS_IMPLIES= LAPACK
SPARSE_DESC= Sparse linear algebra library
CXSPARSE_DESC= CXSparse support
CXSPARSE_LIB_DEPENDS= libcxsparse.so:math/suitesparse
-CXSPARSE_CMAKE_ON= -DCXSPARSE_INCLUDE_DIR="${LOCALBASE}/include/suitesparse"
+CXSPARSE_CMAKE_ON= -DCXSPARSE_INCLUDE_DIR:PATH="${LOCALBASE}/include/suitesparse"
CXSPARSE_CMAKE_BOOL= CXSPARSE
EIGENSPARSE_DESC= Simplicial Cholesky factorization in Eigen
EIGENSPARSE_CMAKE_BOOL= EIGENSPARSE