aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-26 01:03:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-03-26 01:03:29 +0000
commitd11d667b0e1f759ab1a5133a3dbc9a96f62a77b2 (patch)
tree02881bc9e12230b662c21e4eaa924f47b5ef9ec0 /math/ceres-solver
parent33c754ddf8b8a7ceda7035924ffcebb577ac7b08 (diff)
downloadports-d11d667b0e1f759ab1a5133a3dbc9a96f62a77b2.tar.gz
ports-d11d667b0e1f759ab1a5133a3dbc9a96f62a77b2.zip
Notes
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 49af4a64093f..0cc5f196b70f 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -70,17 +70,17 @@ LAPACK_CMAKE_ON= -DBLAS_LIBRARIES:FILEPATH="${BLASLIB}" \
-DLAPACK_LIBRARIES:FILEPATH="${LAPACKLIB}"
LAPACK_CMAKE_BOOL= LAPACK
ATLAS_USES= blaslapack:atlas
-ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS"
+ATLAS_MAKE_ENV= BLA_VENDOR=ATLAS
ATLAS_IMPLIES= LAPACK
GOTOBLAS_DESC= Goto blas implementation
GOTOBLAS_USES= blaslapack:gotoblas
-GOTOBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="Goto"
+GOTOBLAS_MAKE_ENV= BLA_VENDOR=Goto
GOTOBLAS_IMPLIES= LAPACK
NETLIB_USES= blaslapack:netlib
-NETLIB_CMAKE_ON= -DBLA_VENDOR:STRING="Generic"
+NETLIB_MAKE_ENV= BLA_VENDOR=Generic
NETLIB_IMPLIES= LAPACK
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="OpenBLAS"
+OPENBLAS_MAKE_ENV= BLA_VENDOR=OpenBLAS
OPENBLAS_IMPLIES= LAPACK
SPARSE_DESC= Sparse linear algebra library