aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-04 01:05:44 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-04 01:05:44 +0000
commit4ef0eca12a06236f13b6baea84c540fb513b8447 (patch)
tree123fce309c4b730dfb0071ef96ba08a3c0b9c144 /math/ceres-solver
parentebc5408de99940ce4eb411ec57aa021e6991a050 (diff)
downloadports-4ef0eca12a06236f13b6baea84c540fb513b8447.tar.gz
ports-4ef0eca12a06236f13b6baea84c540fb513b8447.zip
Notes
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile14
-rw-r--r--math/ceres-solver/distinfo6
-rw-r--r--math/ceres-solver/files/patch-CMakeLists.txt13
-rw-r--r--math/ceres-solver/pkg-plist16
4 files changed, 16 insertions, 33 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index ecbb9d804f25..224a3c7d4145 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ceres-solver
-DISTVERSION= 1.14.0
-PORTREVISION= 19
+DISTVERSION= 2.0.0
CATEGORIES= math
MAINTAINER= jbeich@FreeBSD.org
@@ -19,7 +18,7 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
scripts/make_docs.py
-CMAKE_ON= CXX11 BUILD_SHARED_LIBS
+CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_BENCHMARKS
LDFLAGS+= -Wl,--as-needed # -lccolamd -lcholmod -lrt from suitesparse
PLIST_SUB= VERSION=${DISTVERSION:C/rc.*//}
@@ -28,11 +27,10 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-solver//}
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= CUSTOM_BLAS EXAMPLES DOCS GFLAGS LAPACK SCHUR TEST
+OPTIONS_DEFINE= CUSTOM_BLAS EXAMPLES DOCS GFLAGS LAPACK OPENMP SCHUR TEST
OPTIONS_DEFAULT=CUSTOM_BLAS CXSPARSE OPENBLAS OPENMP SCHUR SUITESPARSE
OPTIONS_RADIO= LAPACK THREADS
OPTIONS_RADIO_LAPACK= ATLAS GOTOBLAS NETLIB OPENBLAS
-OPTIONS_RADIO_THREADS= OPENMP TBB
OPTIONS_GROUP= SPARSE
OPTIONS_GROUP_SPARSE= CXSPARSE EIGENSPARSE SUITESPARSE
@@ -51,7 +49,7 @@ GFLAGS_LIB_DEPENDS= libgflags.so:devel/gflags
GFLAGS_CMAKE_BOOL= GFLAGS
OPENMP_USES= compiler:openmp
-OPENMP_CMAKE_BOOL= OPENMP
+OPENMP_CMAKE_ON= -DCERES_THREADING_MODEL:STRING="OPENMP"
.if !exists(/usr/include/omp.h)
# XXX ports/199603: LLVM openmp in base doesn't support aarch64, armv6, armv7 yet
OPENMP_VARS= OPENMP=gcc-
@@ -60,10 +58,6 @@ OPENMP_VARS= OPENMP=gcc-
SCHUR_DESC= Fixed-size schur specializations
SCHUR_CMAKE_BOOL= SCHUR_SPECIALIZATIONS
-TBB_DESC= Intel threading building blocks
-TBB_LIB_DEPENDS= libtbb.so:devel/tbb
-TBB_CMAKE_BOOL= TBB
-
# XXX Unbundle googletest/googlemock
TEST_CMAKE_BOOL= BUILD_TESTING
TEST_TEST_TARGET= test
diff --git a/math/ceres-solver/distinfo b/math/ceres-solver/distinfo
index 414c93783849..8298a36e33b4 100644
--- a/math/ceres-solver/distinfo
+++ b/math/ceres-solver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521691214
-SHA256 (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 1296330fcf1e09e6c2f926301916f64d4a4c5c0ff12d460a9bc5d4c48411518f
-SIZE (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 3654161
+TIMESTAMP = 1603478168
+SHA256 (ceres-solver-ceres-solver-2.0.0_GH0.tar.gz) = 2ab0348e0f65fdf43bebcd325a1c73f7e8999691ee75e2a2981281931c42e9fa
+SIZE (ceres-solver-ceres-solver-2.0.0_GH0.tar.gz) = 3708201
diff --git a/math/ceres-solver/files/patch-CMakeLists.txt b/math/ceres-solver/files/patch-CMakeLists.txt
deleted file mode 100644
index 1b4b708c8128..000000000000
--- a/math/ceres-solver/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/ceres-solver/ceres-solver/issues/355
-
---- CMakeLists.txt.orig 2018-03-22 04:00:14 UTC
-+++ CMakeLists.txt
-@@ -435,7 +435,7 @@ if (CXX11 AND COMPILER_HAS_CXX11_FLAG)
- # Update CMAKE_REQUIRED_FLAGS used by CheckCXXSourceCompiles to include
- # -std=c++11 s/t we will detect the C++11 versions of unordered_map &
- # shared_ptr if they exist.
-- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -std=c++11")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
- endif (CXX11 AND COMPILER_HAS_CXX11_FLAG)
-
- # Set the Ceres compile definitions for the unordered_map configuration.
diff --git a/math/ceres-solver/pkg-plist b/math/ceres-solver/pkg-plist
index ed66052a2db3..512210ade0b8 100644
--- a/math/ceres-solver/pkg-plist
+++ b/math/ceres-solver/pkg-plist
@@ -1,4 +1,5 @@
include/ceres/autodiff_cost_function.h
+include/ceres/autodiff_first_order_function.h
include/ceres/autodiff_local_parameterization.h
include/ceres/c_api.h
include/ceres/ceres.h
@@ -14,21 +15,24 @@ include/ceres/dynamic_cost_function.h
include/ceres/dynamic_cost_function_to_functor.h
include/ceres/dynamic_numeric_diff_cost_function.h
include/ceres/evaluation_callback.h
-include/ceres/fpclassify.h
+include/ceres/first_order_function.h
include/ceres/gradient_checker.h
include/ceres/gradient_problem.h
include/ceres/gradient_problem_solver.h
+include/ceres/internal/array_selector.h
include/ceres/internal/autodiff.h
include/ceres/internal/config.h
include/ceres/internal/disable_warnings.h
include/ceres/internal/eigen.h
include/ceres/internal/fixed_array.h
-include/ceres/internal/macros.h
-include/ceres/internal/manual_constructor.h
+include/ceres/internal/householder_vector.h
+include/ceres/internal/integer_sequence_algorithm.h
+include/ceres/internal/line_parameterization.h
+include/ceres/internal/memory.h
include/ceres/internal/numeric_diff.h
+include/ceres/internal/parameter_dims.h
include/ceres/internal/port.h
include/ceres/internal/reenable_warnings.h
-include/ceres/internal/scoped_ptr.h
include/ceres/internal/variadic_evaluate.h
include/ceres/iteration_callback.h
include/ceres/jet.h
@@ -51,9 +55,7 @@ lib/cmake/Ceres/CeresConfig.cmake
lib/cmake/Ceres/CeresConfigVersion.cmake
lib/cmake/Ceres/CeresTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Ceres/CeresTargets.cmake
-lib/cmake/Ceres/FindEigen.cmake
-lib/cmake/Ceres/FindGflags.cmake
lib/cmake/Ceres/FindGlog.cmake
lib/libceres.so
-lib/libceres.so.1
+lib/libceres.so.2
lib/libceres.so.%%VERSION%%