aboutsummaryrefslogtreecommitdiff
path: root/math/cgal/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-09-13 07:38:40 +0000
committerWen Heping <wen@FreeBSD.org>2017-09-13 07:38:40 +0000
commitf352e5291520115e5e3199ed080e5d48c621a346 (patch)
treea9b8354fdbcab2e5cd0bcf7b0da4a51a8bd49d4c /math/cgal/Makefile
parent7fcf51e52d1a8a79702f514ca8e77bb1ea91448b (diff)
downloadports-f352e5291520115e5e3199ed080e5d48c621a346.tar.gz
ports-f352e5291520115e5e3199ed080e5d48c621a346.zip
Notes
Diffstat (limited to 'math/cgal/Makefile')
-rw-r--r--math/cgal/Makefile39
1 files changed, 25 insertions, 14 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index 90d3efc04b29..4ff00853693c 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -3,10 +3,10 @@
PORTNAME= cgal
PORTVERSION= 4.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
-MASTER_SITES= https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-4.9/
-DISTNAME= CGAL-${PORTVERSION}
+MASTER_SITES= https://github.com/${PORTNAME:tu}/${PORTNAME}/releases/download/releases/${DISTNAME}/
+DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Computational geometry library
@@ -14,26 +14,37 @@ COMMENT= Computational geometry library
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
-RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
-LIB_DEPENDS= libmpfr.so:math/mpfr \
+BROKEN_sparc64= does not build: fails to compile all_files.cpp
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
+ ${LOCALBASE}/lib/libntl.a:math/ntl
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libmpfr.so:math/mpfr \
libgmp.so:math/gmp
-BROKEN_sparc64= does not build: fails to compile all_files.cpp
+#TODO math/mpfi, math/rs, graphics/qglviewer
+#Not yet in ports
-USE_LDCONFIG= yes
USES= cmake shebangfix tar:xz
-USE_QT5= buildtools_build core gui opengl qmake_build widgets
+USE_LDCONFIG= yes
SHEBANG_FILES= scripts/cgal_create_CMakeLists \
scripts/cgal_create_cmake_script
+OPTIONS_DEFINE= VISUALIZATION QT5
+VISUALIZATION_IMPLIES= QT5
+OPTIONS_SUB= yes
+
+VISUALIZATION_DESC= Visualization Required for most demos (Qt5 Geomview)
+VISUALIZATION_LIB_DEPENDS= libgeomview.so:graphics/geomview
+
.include <bsd.port.options.mk>
-.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ((${OSVERSION} >= 1100000 && ${OSVERSION} < 1100508) || (${OSVERSION} >= 1200000 && ${OSVERSION} < 1200017))
-# clang internal error in clang 3.8
-BUILD_DEPENDS+= clang39:devel/llvm39
-CC= clang39
-CXX= clang++39
+.if ${PORT_OPTIONS:MQT5}
+CMAKE_ARGS+= -DWITH_CGAL_Qt5=ON
+USE_QT5+= core gui opengl widgets svg buildtools_build qmake_build
+USE_GL+= gl glu
+.else
+CMAKE_ARGS+= -DWITH_CGAL_Qt5=OFF
.endif
.include <bsd.port.mk>