aboutsummaryrefslogtreecommitdiff
path: root/math/cgal/files
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-07-05 09:02:06 +0000
committerWen Heping <wen@FreeBSD.org>2016-07-05 09:02:06 +0000
commit244d506562b7b027f9ec351f1a42edd172870c77 (patch)
tree7caa39ed44cc853237ce5fb02c8acf8fea196e29 /math/cgal/files
parent08d922b726a1320aea644af4224b1e1ce58f883d (diff)
Notes
Diffstat (limited to 'math/cgal/files')
-rw-r--r--math/cgal/files/patch-CMakeLists.txt34
-rw-r--r--math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h16
-rw-r--r--math/cgal/files/patch-include_CGAL_config.h4
-rw-r--r--math/cgal/files/patch-src_CMakeLists.txt24
4 files changed, 15 insertions, 63 deletions
diff --git a/math/cgal/files/patch-CMakeLists.txt b/math/cgal/files/patch-CMakeLists.txt
index 08d59e928efa..a86adc697c92 100644
--- a/math/cgal/files/patch-CMakeLists.txt
+++ b/math/cgal/files/patch-CMakeLists.txt
@@ -1,28 +1,20 @@
---- CMakeLists.txt.orig 2012-10-17 14:00:39.000000000 -0500
-+++ CMakeLists.txt 2013-03-17 15:51:01.000000000 -0500
-@@ -801,9 +801,9 @@
+--- CMakeLists.txt.orig 2016-06-13 12:37:16 UTC
++++ CMakeLists.txt
+@@ -729,7 +729,7 @@ set ( CGAL_INSTALL_DOC_DIR "share/doc/${
+ CACHE STRING "The folder where CGAL documentation and license files will be installed, relative to CMAKE_INSTALL_PREFIX"
+ )
+-set ( CGAL_INSTALL_MAN_DIR "share/man/man1"
++set ( CGAL_INSTALL_MAN_DIR "man/man1"
+ CACHE STRING "The folder where manual pages for CGAL scripts will be installed, relative to CMAKE_INSTALL_PREFIX"
+ )
+
+@@ -816,7 +816,7 @@ create_CGALconfig_files()
# DESTINATION option is mandatory; skipping it breaks CPack!
--if(CGAL_INSTALL_DOC_DIR)
+ if(CGAL_INSTALL_DOC_DIR)
- install(FILES AUTHORS CHANGES LICENSE LICENSE.FREE_USE LICENSE.GPL LICENSE.LGPL DESTINATION ${CGAL_INSTALL_DOC_DIR} )
--endif()
-+#if(CGAL_INSTALL_DOC_DIR)
+# install(FILES AUTHORS CHANGES LICENSE LICENSE.FREE_USE LICENSE.GPL LICENSE.LGPL DESTINATION ${CGAL_INSTALL_DOC_DIR} )
-+#endif()
+ endif()
#install all includes collected in trunk et cetera
-
-@@ -843,9 +843,9 @@
-
- install(FILES ${CMAKE_BINARY_DIR}/config/CGALConfig.cmake DESTINATION ${CGAL_INSTALL_CMAKE_DIR} )
-
--if(CGAL_INSTALL_MAN_DIR)
-- install(FILES auxiliary/cgal_create_cmake_script.1 DESTINATION ${CGAL_INSTALL_MAN_DIR} )
--endif()
-+#if(CGAL_INSTALL_MAN_DIR)
-+# install(FILES auxiliary/cgal_create_cmake_script.1 DESTINATION ${CGAL_INSTALL_MAN_DIR} )
-+#endif()
-
- #--------------------------------------------------------------------------------------------------
- #
diff --git a/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h b/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h
deleted file mode 100644
index 17aeede9dc54..000000000000
--- a/math/cgal/files/patch-include_CGAL_Straight__skeleton_2_Straight_skeleton_builder_2_impl.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- include/CGAL/Straight_skeleton_2/Straight_skeleton_builder_2_impl.h.orig 2014-08-29 14:14:56 UTC
-+++ include/CGAL/Straight_skeleton_2/Straight_skeleton_builder_2_impl.h
-@@ -21,6 +21,13 @@
-
- #include <boost/bind.hpp>
- #include <boost/utility.hpp>
-+
-+// Workaround for boost bug #11880
-+#include <boost/version.hpp>
-+#if BOOST_VERSION == 106000
-+ #include <boost/type_traits/ice.hpp>
-+#endif
-+
- #include <boost/graph/adjacency_matrix.hpp>
- #include <CGAL/Unique_hash_map.h>
-
diff --git a/math/cgal/files/patch-include_CGAL_config.h b/math/cgal/files/patch-include_CGAL_config.h
index aaadeab93ceb..ca0562243359 100644
--- a/math/cgal/files/patch-include_CGAL_config.h
+++ b/math/cgal/files/patch-include_CGAL_config.h
@@ -1,6 +1,6 @@
---- include/CGAL/config.h.orig 2015-05-14 09:38:12 UTC
+--- include/CGAL/config.h.orig 2016-07-05 08:44:07 UTC
+++ include/CGAL/config.h
-@@ -255,7 +255,8 @@
+@@ -296,7 +296,8 @@
|| defined(__x86_64) || defined(__x86_64__) \
|| defined(__ia64) || defined(__ia64__) \
|| defined(_M_IX86) || defined(_M_IA64) \
diff --git a/math/cgal/files/patch-src_CMakeLists.txt b/math/cgal/files/patch-src_CMakeLists.txt
deleted file mode 100644
index 0b164c96cedb..000000000000
--- a/math/cgal/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-commit 61e61220eb43ea8c3d4a6ebd84d44b0510d8533d
-Author: Philipp Möller <bootsarehax@gmail.com>
-Date: Mon Jun 22 11:14:04 2015 +0200
-
- Use get_filename_component to manipulate paths
-
- This caused a bug in CMake>=3.3.0 when file(GLOB) is not adding multiple
- slashes. The lack of trailing slashes is guaranteed and documented in
- get_filename_component.
-
---- src/CMakeLists.txt
-+++ src/CMakeLists.txt
-@@ -117,8 +117,9 @@ set(CGAL_CONFIGURED_LIBRARIES "")
- foreach(package ${CGAL_CONFIGURED_PACKAGES})
- file(GLOB CONFIGURED_LIBS_IN_PACKAGE ${package}/src/CGAL_*/CMakeLists.txt)
- foreach (libconfigfile ${CONFIGURED_LIBS_IN_PACKAGE})
-- string(REPLACE "${package}/src/" "" libconfigfile ${libconfigfile})
-- string(REPLACE "//CMakeLists.txt" "" CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile})
-+ get_filename_component(CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile} DIRECTORY)
-+ get_filename_component(CGAL_CONFIGURED_LIBRARY_NAME ${CGAL_CONFIGURED_LIBRARY_NAME} NAME)
-+
- if (NOT ${CGAL_CONFIGURED_LIBRARY_NAME} STREQUAL "CGAL")
-
- message(STATUS "Sources for CGAL component library '${CGAL_CONFIGURED_LIBRARY_NAME}' detected")