aboutsummaryrefslogtreecommitdiff
path: root/math/cgal
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 12:09:53 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-07 12:09:53 +0000
commitcfc6c4293039552f202f876335e4b66c3747e29a (patch)
treeffb571025437522673ec34290c9b44247880bed5 /math/cgal
parent679e84470dc12a145262007bd7529a3bdd65f0c7 (diff)
downloadports-cfc6c4293039552f202f876335e4b66c3747e29a.tar.gz
ports-cfc6c4293039552f202f876335e4b66c3747e29a.zip
Notes
Diffstat (limited to 'math/cgal')
-rw-r--r--math/cgal/files/patch-src_CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/cgal/files/patch-src_CMakeLists.txt b/math/cgal/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..0b164c96cedb
--- /dev/null
+++ b/math/cgal/files/patch-src_CMakeLists.txt
@@ -0,0 +1,24 @@
+commit 61e61220eb43ea8c3d4a6ebd84d44b0510d8533d
+Author: Philipp Möller <bootsarehax@gmail.com>
+Date: Mon Jun 22 11:14:04 2015 +0200
+
+ Use get_filename_component to manipulate paths
+
+ This caused a bug in CMake>=3.3.0 when file(GLOB) is not adding multiple
+ slashes. The lack of trailing slashes is guaranteed and documented in
+ get_filename_component.
+
+--- src/CMakeLists.txt
++++ src/CMakeLists.txt
+@@ -117,8 +117,9 @@ set(CGAL_CONFIGURED_LIBRARIES "")
+ foreach(package ${CGAL_CONFIGURED_PACKAGES})
+ file(GLOB CONFIGURED_LIBS_IN_PACKAGE ${package}/src/CGAL_*/CMakeLists.txt)
+ foreach (libconfigfile ${CONFIGURED_LIBS_IN_PACKAGE})
+- string(REPLACE "${package}/src/" "" libconfigfile ${libconfigfile})
+- string(REPLACE "//CMakeLists.txt" "" CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile})
++ get_filename_component(CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile} DIRECTORY)
++ get_filename_component(CGAL_CONFIGURED_LIBRARY_NAME ${CGAL_CONFIGURED_LIBRARY_NAME} NAME)
++
+ if (NOT ${CGAL_CONFIGURED_LIBRARY_NAME} STREQUAL "CGAL")
+
+ message(STATUS "Sources for CGAL component library '${CGAL_CONFIGURED_LIBRARY_NAME}' detected")