aboutsummaryrefslogtreecommitdiff
path: root/math/cgl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-16 07:22:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-16 07:22:08 +0000
commitc03b1a0bb112fa84dd0c40ba7f4aaa73fea0f650 (patch)
treeed77b1808ec31da578dceeb7123b3e95dd3760d5 /math/cgl
parent5532e65810d8bafa5f1da832834bff6f68b94298 (diff)
downloadports-c03b1a0bb112fa84dd0c40ba7f4aaa73fea0f650.tar.gz
ports-c03b1a0bb112fa84dd0c40ba7f4aaa73fea0f650.zip
Notes
Diffstat (limited to 'math/cgl')
-rw-r--r--math/cgl/Makefile27
-rw-r--r--math/cgl/distinfo3
-rw-r--r--math/cgl/files/patch-Cgl_src_CglLandP_CglLandPUtils.hpp11
-rw-r--r--math/cgl/pkg-descr5
-rw-r--r--math/cgl/pkg-plist39
5 files changed, 85 insertions, 0 deletions
diff --git a/math/cgl/Makefile b/math/cgl/Makefile
new file mode 100644
index 000000000000..2996ca932529
--- /dev/null
+++ b/math/cgl/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= cgl
+DISTVERSIONPREFIX= releases/
+DISTVERSION= 0.59.10
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of cut generators for COIN-OR packages that use cuts
+
+LICENSE= EPL
+
+LIB_DEPENDS= libblas.so:math/blas \
+ libClp.so:math/clp \
+ liblapack.so:math/lapack
+
+USES= gmake libtool pkgconfig
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or
+GH_PROJECT= Cgl
+USE_LDCONFIG= yes
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libCgl.so.*
+
+.include <bsd.port.mk>
diff --git a/math/cgl/distinfo b/math/cgl/distinfo
new file mode 100644
index 000000000000..da1336c16add
--- /dev/null
+++ b/math/cgl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522615098
+SHA256 (coin-or-Cgl-releases-0.59.10_GH0.tar.gz) = 2a4038dfeb00b4f4084bbe00b144b6bae4ddfe87873ac5913603af248cb3f1d4
+SIZE (coin-or-Cgl-releases-0.59.10_GH0.tar.gz) = 1255366
diff --git a/math/cgl/files/patch-Cgl_src_CglLandP_CglLandPUtils.hpp b/math/cgl/files/patch-Cgl_src_CglLandP_CglLandPUtils.hpp
new file mode 100644
index 000000000000..f10ff52b59d4
--- /dev/null
+++ b/math/cgl/files/patch-Cgl_src_CglLandP_CglLandPUtils.hpp
@@ -0,0 +1,11 @@
+--- Cgl/src/CglLandP/CglLandPUtils.hpp.orig 2018-04-16 07:09:23 UTC
++++ Cgl/src/CglLandP/CglLandPUtils.hpp
+@@ -85,7 +85,7 @@ struct Cuts
+ /** resize vector.*/
+ void resize(unsigned int i)
+ {
+- cuts_.resize(i, reinterpret_cast<OsiRowCut *> (NULL));
++ cuts_.resize(i, nullptr); // workaround for clang-6
+ }
+ private:
+ /** Stores the number of cuts.*/
diff --git a/math/cgl/pkg-descr b/math/cgl/pkg-descr
new file mode 100644
index 000000000000..c69be1cf9a04
--- /dev/null
+++ b/math/cgl/pkg-descr
@@ -0,0 +1,5 @@
+Collection of cut generators that can be used with other COIN-OR packages
+that make use of cuts, such as, among others, the linear solver Clp or the
+mixed integer linear programming solvers Cbc or BCP.
+
+WWW: https://projects.coin-or.org/Cgl
diff --git a/math/cgl/pkg-plist b/math/cgl/pkg-plist
new file mode 100644
index 000000000000..b0d352a99b98
--- /dev/null
+++ b/math/cgl/pkg-plist
@@ -0,0 +1,39 @@
+include/coin/Cgl012cut.hpp
+include/coin/CglAllDifferent.hpp
+include/coin/CglClique.hpp
+include/coin/CglConfig.h
+include/coin/CglCutGenerator.hpp
+include/coin/CglDuplicateRow.hpp
+include/coin/CglFlowCover.hpp
+include/coin/CglGMI.hpp
+include/coin/CglGMIParam.hpp
+include/coin/CglGomory.hpp
+include/coin/CglKnapsackCover.hpp
+include/coin/CglLandP.hpp
+include/coin/CglLandPValidator.hpp
+include/coin/CglLiftAndProject.hpp
+include/coin/CglMessage.hpp
+include/coin/CglMixedIntegerRounding.hpp
+include/coin/CglMixedIntegerRounding2.hpp
+include/coin/CglOddHole.hpp
+include/coin/CglParam.hpp
+include/coin/CglPreProcess.hpp
+include/coin/CglProbing.hpp
+include/coin/CglRedSplit.hpp
+include/coin/CglRedSplit2.hpp
+include/coin/CglRedSplit2Param.hpp
+include/coin/CglRedSplitParam.hpp
+include/coin/CglResidualCapacity.hpp
+include/coin/CglSimpleRounding.hpp
+include/coin/CglStored.hpp
+include/coin/CglTreeInfo.hpp
+include/coin/CglTwomir.hpp
+include/coin/CglZeroHalf.hpp
+lib/libCgl.so
+lib/libCgl.so.1
+lib/libCgl.so.1.9.10
+libdata/pkgconfig/cgl.pc
+share/coin/doc/Cgl/AUTHORS
+share/coin/doc/Cgl/LICENSE
+share/coin/doc/Cgl/README
+share/coin/doc/Cgl/cgl_addlibs.txt