aboutsummaryrefslogtreecommitdiff
path: root/math/clarence/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 18:43:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 18:43:02 +0000
commit403038cd4d3205149481a7ba7d440d9d6b5eec8c (patch)
treea67235478a631bc772fc9c1080a73ea9e62d1ecd /math/clarence/Makefile
parent2f056dc832b7f191aceb52cb3730edcbc78e6b1a (diff)
add clarence 0.1.8
Programmer's calculator
Notes
Notes: svn path=/head/; revision=54038
Diffstat (limited to 'math/clarence/Makefile')
-rw-r--r--math/clarence/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/clarence/Makefile b/math/clarence/Makefile
new file mode 100644
index 000000000000..a74615a15536
--- /dev/null
+++ b/math/clarence/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: clarence
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= clarence
+PORTVERSION= 0.1.8
+CATEGORIES= math python
+MASTER_SITES= http://nrn.ll.pl/pasp/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/GDK.py:${PORTSDIR}/x11-toolkits/py-gtk
+
+USE_PYTHON= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,#!/usr/bin/python,#!/usr/bin/env python,g" ${WRKSRC}/clarence.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/clarence.py ${PREFIX}/bin/clarence
+
+.include <bsd.port.mk>