aboutsummaryrefslogtreecommitdiff
path: root/math/clarence
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-20 15:14:08 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-20 15:14:08 +0000
commit79d72afcd4dbc05f6110de1e4b8644dc2a0890a8 (patch)
tree89b6d00ad6e9e6f88ba9239b0d245837e1cca50b /math/clarence
parent4f288304ec666b2d4e5f592f11633ac4f5ead790 (diff)
downloadports-79d72afcd4dbc05f6110de1e4b8644dc2a0890a8.tar.gz
ports-79d72afcd4dbc05f6110de1e4b8644dc2a0890a8.zip
Notes
Diffstat (limited to 'math/clarence')
-rw-r--r--math/clarence/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/clarence/Makefile b/math/clarence/Makefile
index fb33d459d978..b7ce17daba64 100644
--- a/math/clarence/Makefile
+++ b/math/clarence/Makefile
@@ -11,18 +11,17 @@ MASTER_SITES= http://www.sourcefiles.org/Productivity_Tools/Calculators/ \
MAINTAINER= psh@iki.fi
COMMENT= Programmer's calculator
+USES= shebangfix
USE_GNOME= pygtk2
USE_PYTHON= yes
NO_BUILD= yes
-MAN1= clarence.1
-PLIST_FILES= bin/clarence
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,#!/usr/bin/python,#!/usr/bin/env python,g" ${WRKSRC}/clarence.py
+PLIST_FILES= bin/clarence man/man1/clarence.1.gz
+SHEBANG_FILES= clarence.py
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/clarence.py ${PREFIX}/bin/clarence
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/clarence.py \
+ ${STAGEDIR}${PREFIX}/bin/clarence
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>