aboutsummaryrefslogtreecommitdiff
path: root/math/clasp
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2013-11-01 15:53:37 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2013-11-01 15:53:37 +0000
commit5887dd9a4d102296aa639ed38e3aecd95cd5a783 (patch)
treed644364a6a19b914fa1cb6bb17f6e50775475c78 /math/clasp
parentf0a869ee10fc4fc604890174adfd1ce9b6572246 (diff)
downloadports-5887dd9a4d102296aa639ed38e3aecd95cd5a783.tar.gz
ports-5887dd9a4d102296aa639ed38e3aecd95cd5a783.zip
Notes
Diffstat (limited to 'math/clasp')
-rw-r--r--math/clasp/Makefile4
-rw-r--r--math/clasp/files/patch-libclasp-clasp-util-platform.h11
2 files changed, 13 insertions, 2 deletions
diff --git a/math/clasp/Makefile b/math/clasp/Makefile
index e6c9e37ff689..c217c7a2f92e 100644
--- a/math/clasp/Makefile
+++ b/math/clasp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clasp
PORTVERSION= 2.1.3
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= potassco/${PORTNAME}/${PORTVERSION}
@@ -15,8 +16,7 @@ USES= cmake:outsource
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${INSTALL} ${INSTALL_WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/math/clasp/files/patch-libclasp-clasp-util-platform.h b/math/clasp/files/patch-libclasp-clasp-util-platform.h
new file mode 100644
index 000000000000..242e350c52fa
--- /dev/null
+++ b/math/clasp/files/patch-libclasp-clasp-util-platform.h
@@ -0,0 +1,11 @@
+--- libclasp/clasp/util/platform.h.orig 1970-09-03 18:56:56.000000000 +0100
++++ libclasp/clasp/util/platform.h 1970-09-03 19:04:47.000000000 +0100
+@@ -107,7 +107,7 @@
+ template <bool> struct static_assertion;
+ template <> struct static_assertion<true> {};
+
+-#if !defined(__cplusplus) || __cplusplus < 201103L
++#if !defined(__cplusplus) || !defined(static_assert)
+ #define static_assert(x, message) (void)sizeof(static_assertion< (x) >)
+ #endif
+