aboutsummaryrefslogtreecommitdiff
path: root/math/clblast
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2017-06-02 00:14:04 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2017-06-02 00:14:04 +0000
commit4649989b3d21eb38b41b09c34503b4ae3abec31c (patch)
treee6fd4fec11c802c0398d519cb27231b61358812f /math/clblast
parentbe27a4032faea3a7081b4690f46a6a27462f8052 (diff)
downloadports-4649989b3d21eb38b41b09c34503b4ae3abec31c.tar.gz
ports-4649989b3d21eb38b41b09c34503b4ae3abec31c.zip
Notes
Diffstat (limited to 'math/clblast')
-rw-r--r--math/clblast/Makefile29
-rw-r--r--math/clblast/distinfo3
-rw-r--r--math/clblast/pkg-descr4
-rw-r--r--math/clblast/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/math/clblast/Makefile b/math/clblast/Makefile
new file mode 100644
index 000000000000..6718d3f6e8b1
--- /dev/null
+++ b/math/clblast/Makefile
@@ -0,0 +1,29 @@
+# Created by: Johannes M Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= clblast
+PORTVERSION= 0.11.0
+CATEGORIES= math
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= Modern, lightweight, performant and tunable OpenCL BLAS library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:devel/opencl
+LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
+RUN_DEPENDS= opencl>=0:devel/opencl
+
+USE_GITHUB= yes
+GH_ACCOUNT= CNugteren
+GH_PROJECT= CLBlast
+
+USE_LDCONFIG= yes
+USES= cmake
+
+post-install:
+ @${MV} ${STAGEDIR}/${PREFIX}/lib/pkgconfig/clblast.pc ${STAGEDIR}/${PREFIX}/libdata/pkgconfig/clblast.pc
+ @${RM} -r ${STAGEDIR}/${PREFIX}/lib/pkgconfig
+
+.include <bsd.port.mk>
diff --git a/math/clblast/distinfo b/math/clblast/distinfo
new file mode 100644
index 000000000000..3c11dc518775
--- /dev/null
+++ b/math/clblast/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495679439
+SHA256 (CNugteren-CLBlast-0.11.0_GH0.tar.gz) = 947182733e51f9fc8317896047c95cf07fb3cd5f14437ea25a38e013f42f8e53
+SIZE (CNugteren-CLBlast-0.11.0_GH0.tar.gz) = 557469
diff --git a/math/clblast/pkg-descr b/math/clblast/pkg-descr
new file mode 100644
index 000000000000..4dd1ed24b156
--- /dev/null
+++ b/math/clblast/pkg-descr
@@ -0,0 +1,4 @@
+Modern, lightweight, performant and tunable OpenCL BLAS library. Tuned for
+Intel, AMD, and NVIDIA accelerators.
+
+WWW: https://github.com/CNugteren/CLBlast
diff --git a/math/clblast/pkg-plist b/math/clblast/pkg-plist
new file mode 100644
index 000000000000..9de75badbf3d
--- /dev/null
+++ b/math/clblast/pkg-plist
@@ -0,0 +1,7 @@
+include/clblast.h
+include/clblast_c.h
+include/clblast_half.h
+lib/cmake/CLBLast/CLBlastConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/CLBLast/CLBlastConfig.cmake
+lib/libclblast.so
+libdata/pkgconfig/clblast.pc