aboutsummaryrefslogtreecommitdiff
path: root/math/clp/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-15 19:32:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-15 19:32:34 +0000
commit66cb24086df39acf6330a46666c2125ff523d567 (patch)
tree07cec6aff8cd5195b68e5fb5c251c45056da23c3 /math/clp/Makefile
parent9757f7b03f1da5ef5b9d3840416cbc1a05f6e4b3 (diff)
downloadports-66cb24086df39acf6330a46666c2125ff523d567.tar.gz
ports-66cb24086df39acf6330a46666c2125ff523d567.zip
Notes
Diffstat (limited to 'math/clp/Makefile')
-rw-r--r--math/clp/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/math/clp/Makefile b/math/clp/Makefile
index b86a9f4c9811..b87b1626c70f 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Clp
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.0
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/Clp/
EXTRACT_SUFX= .tgz
@@ -14,7 +14,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= co9co9@gmail.com
COMMENT= Linear Programming Solver
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack
+.ifdef WITH_GMPL
+LIB_DEPENDS+= glpk.9:${PORTSDIR}/math/glpk
+.endif
+
+USE_FORTRAN= yes
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV+= ${MAKE_ENV}
+CONFIGURE_ARGS= --with-blas="-L${LOCALBASE}/lib -lblas" \
+ --with-lapack="-L${LOCALBASE}/lib -llapack"
+.ifdef WITH_GMPL
+CONFIGURE_ARGS+=--with-gmpl-incdir=${LOCALBASE}/include/gmpl \
+ --with-gmpl-lib="-L${LOCALBASE}/lib -lglpk"
+.endif
+
.include <bsd.port.mk>