aboutsummaryrefslogtreecommitdiff
path: root/math/coinmp
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-09-11 23:07:59 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-09-11 23:07:59 +0000
commitd1128daf4ea503b7e78793b85b883cd4961a097b (patch)
tree131daf73f9651f09a562a73fe8154c6ed5906b50 /math/coinmp
parent0c2a7edcf88cc5b690b334e3626365a35f087ae2 (diff)
downloadports-d1128daf4ea503b7e78793b85b883cd4961a097b.tar.gz
ports-d1128daf4ea503b7e78793b85b883cd4961a097b.zip
- Use INSTALL_TARGET=install-strip instead of manual stripping
- Fix 'present but cannot be compiled' warnings PR: 231262 Submitted by: avos
Notes
Notes: svn path=/head/; revision=479573
Diffstat (limited to 'math/coinmp')
-rw-r--r--math/coinmp/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/math/coinmp/Makefile b/math/coinmp/Makefile
index 56f850f90e1b..9a8f85a21d94 100644
--- a/math/coinmp/Makefile
+++ b/math/coinmp/Makefile
@@ -44,9 +44,7 @@ GLPK_CONFIGURE_OFF= --disable-glpk-libcheck
PARALLEL_CONFIGURE_ON= --enable-cbc-parallel
-STRIP_FILES= libCoinUtils libOsi libOsiClp libOsiCommonTests libClp libClpSolver \
- libCgl libCbc libCbcSolver libOsiCbc libCoinMP
-
+INSTALL_TARGET= install-strip
TEST_TARGET= unitTest
TEST_WRKSRC= ${WRKSRC}/${PORTNAME}
@@ -56,13 +54,10 @@ post-patch::
-e 's|addlibs_DATA = examples/Makefile examples/example.c||g' \
-e 's|DocInstallDir = $$(datadir)/coin/doc/$$(PACKAGE_NAME)|DocInstallDir = $$(datadir)/doc/CoinMP/$$(PACKAGE_NAME)|' \
-e 's| $$(MAKE) $$(AM_MAKEFLAGS) install-data-hook||'
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|void exit (int)|void reserved (int)|g'
${REINPLACE_CMD} -e 's|datacoin_DATA = $$(EXAMPLE_FILES)|datacoin_DATA = |' \
-e 's|datacoindir = $$(datadir)/coin/Data/Sample|datacoindir = |' ${WRKSRC}/Data/Sample/Makefile.in
${REINPLACE_CMD} -e 's|addlibsdir = $$(DESTDIR)$$(datadir)/coin/doc/CoinMP|addlibsdir = |' ${WRKSRC}/CoinMP/Makefile.in
-post-install:
-.for filename in ${STRIP_FILES}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${filename}.so.*
-.endfor
-
.include <bsd.port.mk>