aboutsummaryrefslogtreecommitdiff
path: root/math/concorde
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-18 12:38:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-18 12:38:19 +0000
commit1c29cac522ebe6fb3a7f1e88b1e5c97b2702779f (patch)
treeef6fb6f4d8aec32abe9968e2c62aaa05b872ca85 /math/concorde
parentf6d7c2bd98c0a3c03075d25d49d0f40048d4dea1 (diff)
downloadports-1c29cac522ebe6fb3a7f1e88b1e5c97b2702779f.tar.gz
ports-1c29cac522ebe6fb3a7f1e88b1e5c97b2702779f.zip
Notes
Diffstat (limited to 'math/concorde')
-rw-r--r--math/concorde/Makefile28
-rw-r--r--math/concorde/distinfo4
-rw-r--r--math/concorde/files/patch-UTIL_urandom.c24
-rw-r--r--math/concorde/files/patch-bigguy-Makefile.in18
-rw-r--r--math/concorde/files/patch-killgrun.c18
-rw-r--r--math/concorde/pkg-descr14
-rw-r--r--math/concorde/pkg-plist35
7 files changed, 97 insertions, 44 deletions
diff --git a/math/concorde/Makefile b/math/concorde/Makefile
index bd6b14e88a28..4d6a6d58d8eb 100644
--- a/math/concorde/Makefile
+++ b/math/concorde/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= concorde
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 20031219
CATEGORIES= math parallel
-MASTER_SITES= http://www.math.princeton.edu/tsp/concorde/ \
- ftp://ftp.caam.rice.edu/pub/software/keck/
-DISTNAME= co991215
+MASTER_SITES= http://www.tsp.gatech.edu/concorde/ \
+ http://www.math.princeton.edu/tsp/concorde/
+DISTNAME= co031219
EXTRACT_SUFX= .tgz
MAINTAINER= dbader@eece.unm.edu
@@ -19,14 +18,24 @@ COMMENT= Combinatorial Optimization package
WRKSRC= ${WRKDIR}/concorde
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
+ALL_TARGET= everything
INCFILES= bigguy.h combs.h config.h consec1.h cut.h cuttree.h \
delaunay.h edgegen.h fmatch.h heldkarp.h kdtree.h \
linkern.h localcut.h lp.h machdefs.h macrorus.h mlinkern.h \
- necklace.h pq.h pqsets.h profdata.h profrus.h tinytsp.h \
+ necklace.h pq.h pqsets.h tinytsp.h \
tsp.h util.h verify.h
+BINFILES= BIGGUY/bg_test COMBS/combtest CUT/lin_all CUT/mincut \
+ EDGEGEN/edgegen FMATCH/fmatch HELDKARP/heldkarp KDTREE/kdtree \
+ LINKERN/linkern LOCALCUT/checker LOCALCUT/first \
+ LOCALCUT/localcut LOCALCUT/peeler LOCALCUT/peeler2 PQ/pqtest \
+ TINY/tinytsp TOOLS/edg2len TOOLS/edgunion TOOLS/fconvert \
+ TOOLS/killgrun TOOLS/prob2tsp TOOLS/showres TOOLS/tourchk \
+ TOOLS/tourlen TSP/bosstell TSP/concorde TSP/cutserv \
+ TSP/poolcat TSP/probserv TSP/test_tsp VERIFY/verify
+
do-install:
${INSTALL_DATA} ${WRKSRC}/concorde.a ${PREFIX}/lib/libconcorde.a
${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 ${PREFIX}/include/concorde
@@ -34,5 +43,10 @@ do-install:
.for f in ${INCFILES}
${INSTALL_DATA} ${WRKSRC}/INCLUDE/${f} ${PREFIX}/include/concorde
.endfor
+ ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${PREFIX}/bin/concorde
+.for f in ${BINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/concorde
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/TINY/randtsp.awk ${PREFIX}/bin/concorde
.include <bsd.port.mk>
diff --git a/math/concorde/distinfo b/math/concorde/distinfo
index f6cc6a2128eb..e0d4e83d5869 100644
--- a/math/concorde/distinfo
+++ b/math/concorde/distinfo
@@ -1,2 +1,2 @@
-MD5 (co991215.tgz) = 30c7dcccbde91a03d66e3e715f656650
-SIZE (co991215.tgz) = 732109
+MD5 (co031219.tgz) = 3476e01ae89b591bf7b329b2f5aa0353
+SIZE (co031219.tgz) = 698592
diff --git a/math/concorde/files/patch-UTIL_urandom.c b/math/concorde/files/patch-UTIL_urandom.c
deleted file mode 100644
index f74abbd7ce03..000000000000
--- a/math/concorde/files/patch-UTIL_urandom.c
+++ /dev/null
@@ -1,24 +0,0 @@
-
-$FreeBSD$
-
---- UTIL/urandom.c.orig Thu Dec 16 19:39:06 1999
-+++ UTIL/urandom.c Tue Nov 12 17:10:02 2002
-@@ -22,7 +22,7 @@
- /* */
- /* Written by: DIMACS (modified for TSP) */
- /* Date: February 7, 1995 (cofeb16) */
--/* */
-+/* September 18, 2001 (billenium fix) */
- /* */
- /* EXPORTED FUNCTIONS: */
- /* */
-@@ -66,6 +66,9 @@
- int i, ii;
- int last, next;
- int *arr = r->arr;
-+
-+ seed %= CC_PRANDMAX;
-+ if (seed < 0) seed += CC_PRANDMAX;
-
- arr[0] = last = seed;
- next = 1;
diff --git a/math/concorde/files/patch-bigguy-Makefile.in b/math/concorde/files/patch-bigguy-Makefile.in
new file mode 100644
index 000000000000..9dbc42c832c8
--- /dev/null
+++ b/math/concorde/files/patch-bigguy-Makefile.in
@@ -0,0 +1,18 @@
+--- BIGGUY/Makefile.in.orig Thu Dec 16 20:22:41 1999
++++ BIGGUY/Makefile.in Thu Dec 16 13:06:35 2004
+@@ -37,13 +37,13 @@
+
+ all: $(THISLIB)
+
+-everything: all bg_test test
++everything: all bg_test
+
+ bg_test: bg_test.$o $(THISLIB) $(LIBS)
+ $(CC) $(LDFLAGS) -o $@ bg_test.$o $(THISLIB) $(LIBS) $(LIBFLAGS)
+
+ test: bg_test
+- time bg_test < $(srcdir)/bigguy.tst > bigguy.ts2
++ time ./bg_test < $(srcdir)/bigguy.tst > bigguy.ts2
+ cmp $(srcdir)/bigguy.tst bigguy.ts2
+
+ clean:
diff --git a/math/concorde/files/patch-killgrun.c b/math/concorde/files/patch-killgrun.c
new file mode 100644
index 000000000000..71978f38dd78
--- /dev/null
+++ b/math/concorde/files/patch-killgrun.c
@@ -0,0 +1,18 @@
+--- TOOLS/killgrun.c.orig Thu Dec 16 11:26:57 2004
++++ TOOLS/killgrun.c Thu Dec 16 11:27:06 2004
+@@ -75,13 +75,13 @@
+ if (rval) {
+ perror ("kill");
+ fprintf (stderr, "Unable to kill process %d\n", process);
+-/*
++#if 0
+ if (errno == ESRCH) { /* Does not work on Red Hat 8 */
+ fprintf (stderr, "Process does not exist, telling boss anyway\n");
+ } else {
+ goto CLEANUP;
+ }
+-*/
++#endif
+ fprintf (stderr, "Process does not exist, telling boss anyway\n");
+ }
+ }
diff --git a/math/concorde/pkg-descr b/math/concorde/pkg-descr
index 6ad71758060f..45bb521952c6 100644
--- a/math/concorde/pkg-descr
+++ b/math/concorde/pkg-descr
@@ -1,20 +1,16 @@
-Concorde (99.12.15 release) This is the initial full release of Concorde.
-More data about Concorde is available from the Concorde page at
-http://www.math.princeton.edu/tsp/concorde.html.
-
Concorde is a computer code for the traveling salesman problem (TSP)
and some related network optimization problems. The code is written
in the ANSI C programming language and it is available for academic
-research use; for other uses, contact concorde@caam.rice.edu for
+research use; for other uses, contact bico@isye.gatech.edu for
licensing options.
Concorde's TSP solver has been used to obtain the optimal solutions to
-all TSPLIB instances having up to 13,509 cities.
+106 of the 110 TSPLIB instances; the largest having 15,112 cities.
The Concorde callable library includes over 700 functions permitting
users to create specialized codes for TSP-like problems. All Concorde
-functions are thread-safe for prgramming in shared-memory parallel
+functions are thread-safe for programming in shared-memory parallel
environments; the main TSP solver includes code for running over
-networks of unix workstations.
+networks of Unix workstations.
-WWW: http://www.math.princeton.edu/tsp/concorde.html
+WWW: http://www.tsp.gatech.edu/concorde.html
diff --git a/math/concorde/pkg-plist b/math/concorde/pkg-plist
index d9d433514d63..ac0545093f1c 100644
--- a/math/concorde/pkg-plist
+++ b/math/concorde/pkg-plist
@@ -1,3 +1,35 @@
+bin/concorde/bg_test
+bin/concorde/bosstell
+bin/concorde/checker
+bin/concorde/combtest
+bin/concorde/concorde
+bin/concorde/cutserv
+bin/concorde/edg2len
+bin/concorde/edgegen
+bin/concorde/edgunion
+bin/concorde/fconvert
+bin/concorde/first
+bin/concorde/fmatch
+bin/concorde/heldkarp
+bin/concorde/kdtree
+bin/concorde/killgrun
+bin/concorde/lin_all
+bin/concorde/linkern
+bin/concorde/localcut
+bin/concorde/mincut
+bin/concorde/peeler
+bin/concorde/peeler2
+bin/concorde/poolcat
+bin/concorde/pqtest
+bin/concorde/prob2tsp
+bin/concorde/probserv
+bin/concorde/randtsp.awk
+bin/concorde/showres
+bin/concorde/test_tsp
+bin/concorde/tinytsp
+bin/concorde/tourchk
+bin/concorde/tourlen
+bin/concorde/verify
lib/libconcorde.a
include/concorde/bigguy.h
include/concorde/combs.h
@@ -20,10 +52,9 @@ include/concorde/mlinkern.h
include/concorde/necklace.h
include/concorde/pq.h
include/concorde/pqsets.h
-include/concorde/profdata.h
-include/concorde/profrus.h
include/concorde/tinytsp.h
include/concorde/tsp.h
include/concorde/util.h
include/concorde/verify.h
+@dirrm bin/concorde
@dirrm include/concorde