aboutsummaryrefslogtreecommitdiff
path: root/math/convertall/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:35:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:35:23 +0000
commit424de77b9000f8bc411cd22393d3dce5275727a7 (patch)
treeeb37ebe3410ca416f0306f93d96f0405ff432088 /math/convertall/Makefile
parent498027abe5e110cd794f0120231a132c2563193a (diff)
downloadports-424de77b9000f8bc411cd22393d3dce5275727a7.tar.gz
ports-424de77b9000f8bc411cd22393d3dce5275727a7.zip
Notes
Diffstat (limited to 'math/convertall/Makefile')
-rw-r--r--math/convertall/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
new file mode 100644
index 000000000000..b1e8da8cc280
--- /dev/null
+++ b/math/convertall/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: convertall
+# Date created: 2004-08-12
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= convertall
+PORTVERSION= 0.3.0
+CATEGORIES= math
+MASTER_SITES= http://bellz.org/convertall/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Another unit converter
+
+BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
+RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
+
+WRKSRC= ${WRKDIR}/ConvertAll
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+PORTDOCS= README.html INSTALL LICENSE
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|doc||' ${WRKSRC}/install.py
+.endif
+
+do-install:
+ (cd ${WRKSRC};${PYTHON_CMD} ${WRKSRC}/install.py -p ${PREFIX})
+
+.include <bsd.port.mk>