aboutsummaryrefslogtreecommitdiff
path: root/math/convertall
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:35:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:35:23 +0000
commit424de77b9000f8bc411cd22393d3dce5275727a7 (patch)
treeeb37ebe3410ca416f0306f93d96f0405ff432088 /math/convertall
parent498027abe5e110cd794f0120231a132c2563193a (diff)
downloadports-424de77b9000f8bc411cd22393d3dce5275727a7.tar.gz
ports-424de77b9000f8bc411cd22393d3dce5275727a7.zip
Notes
Diffstat (limited to 'math/convertall')
-rw-r--r--math/convertall/Makefile34
-rw-r--r--math/convertall/distinfo2
-rw-r--r--math/convertall/pkg-descr8
-rw-r--r--math/convertall/pkg-plist36
4 files changed, 80 insertions, 0 deletions
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
new file mode 100644
index 000000000000..b1e8da8cc280
--- /dev/null
+++ b/math/convertall/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: convertall
+# Date created: 2004-08-12
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= convertall
+PORTVERSION= 0.3.0
+CATEGORIES= math
+MASTER_SITES= http://bellz.org/convertall/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Another unit converter
+
+BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
+RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
+
+WRKSRC= ${WRKDIR}/ConvertAll
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+PORTDOCS= README.html INSTALL LICENSE
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|doc||' ${WRKSRC}/install.py
+.endif
+
+do-install:
+ (cd ${WRKSRC};${PYTHON_CMD} ${WRKSRC}/install.py -p ${PREFIX})
+
+.include <bsd.port.mk>
diff --git a/math/convertall/distinfo b/math/convertall/distinfo
new file mode 100644
index 000000000000..f4190a078a6e
--- /dev/null
+++ b/math/convertall/distinfo
@@ -0,0 +1,2 @@
+MD5 (convertall-0.3.0.tar.gz) = 27ca231c02034ba4e2238073c1c2220c
+SIZE (convertall-0.3.0.tar.gz) = 37321
diff --git a/math/convertall/pkg-descr b/math/convertall/pkg-descr
new file mode 100644
index 000000000000..18274393f73f
--- /dev/null
+++ b/math/convertall/pkg-descr
@@ -0,0 +1,8 @@
+[From README.html]
+
+A unit converter that can combine the units any way you want. If
+you want to convert from inches per decade, that's fine. Or from
+meter-pounds. Or from cubic nautical miles. The units don't have to
+make sense to anyone else.
+
+WWW: http://www.bellz.org/convertall/
diff --git a/math/convertall/pkg-plist b/math/convertall/pkg-plist
new file mode 100644
index 000000000000..78c5f364262e
--- /dev/null
+++ b/math/convertall/pkg-plist
@@ -0,0 +1,36 @@
+bin/convertall
+lib/convertall/convertall.py
+lib/convertall/convertall.pyc
+lib/convertall/convertdlg.py
+lib/convertall/convertdlg.pyc
+lib/convertall/finddlg.py
+lib/convertall/finddlg.pyc
+lib/convertall/helpview.py
+lib/convertall/helpview.pyc
+lib/convertall/numedit.py
+lib/convertall/numedit.pyc
+lib/convertall/numeval1.py
+lib/convertall/numeval1.pyc
+lib/convertall/numeval2.py
+lib/convertall/numeval2.pyc
+lib/convertall/option.py
+lib/convertall/option.pyc
+lib/convertall/optiondlg.py
+lib/convertall/optiondlg.pyc
+lib/convertall/tmpcontrol.py
+lib/convertall/tmpcontrol.pyc
+lib/convertall/unit.py
+lib/convertall/unit.pyc
+lib/convertall/unitdata.py
+lib/convertall/unitdata.pyc
+lib/convertall/unitedit.py
+lib/convertall/unitedit.pyc
+lib/convertall/unitgroup.py
+lib/convertall/unitgroup.pyc
+lib/convertall/unitlistview.py
+lib/convertall/unitlistview.pyc
+share/convertall/units.dat
+share/icons/convertall_lg.png
+share/icons/convertall_sm.png
+@dirrm share/convertall
+@dirrm lib/convertall