aboutsummaryrefslogtreecommitdiff
path: root/math/coq
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-01-11 09:31:40 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-01-11 09:31:40 +0000
commitd255abc4f2e51f40b38973d8a2b55633f9f989e5 (patch)
tree89d14765afc4aa86688e2db366a20bb6cf4dc351 /math/coq
parentf424c294c47d5cf8c5fe22610090c59e454d5387 (diff)
downloadports-d255abc4f2e51f40b38973d8a2b55633f9f989e5.tar.gz
ports-d255abc4f2e51f40b38973d8a2b55633f9f989e5.zip
- Update coq to 8.4.3
- Enable stage support - Simplify options handling
Notes
Notes: svn path=/head/; revision=339411
Diffstat (limited to 'math/coq')
-rw-r--r--math/coq/Makefile57
-rw-r--r--math/coq/distinfo4
-rw-r--r--math/coq/pkg-plist16
3 files changed, 39 insertions, 38 deletions
diff --git a/math/coq/Makefile b/math/coq/Makefile
index ba2ca83ae11a..87f8f8c8b886 100644
--- a/math/coq/Makefile
+++ b/math/coq/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= coq
-PORTVERSION= 8.4.2
+PORTVERSION= 8.4.3
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= http://coq.inria.fr/distrib/V${COQVERSION}/files/ \
@@ -16,44 +16,29 @@ BUILD_DEPENDS= camlp5:${PORTSDIR}/devel/ocaml-camlp5 \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
COQVERSION= ${PORTVERSION:R}pl${PORTVERSION:E}
+USES= gmake
USE_OCAML= yes
-USE_GMAKE= yes
ALL_TARGET= world
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix ${PREFIX}
-CONFIGURE_ARGS+=--mandir ${PREFIX}/man
-CONFIGURE_ARGS+=--emacslib ${PREFIX}/share/emacs/site-lisp
-CONFIGURE_ARGS+=--opt
-
-OPTIONS_DEFINE= IDE
-OPTIONS_DEFAULT=IDE
-IDE_DESC= Include desktop environment (coqide)
-
-MAN1= coq-tex.1 coq_makefile.1 coqc.1 coqchk.1 coqdep.1 coqdoc.1 \
- coqmktop.1 coqtop.1 coqtop.byte.1 coqtop.opt.1 coqwc.1 gallina.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-USE_TEX= latex:build dvipsk:build
-BUILD_DEPENDS+= hevea:${PORTSDIR}/textproc/hevea \
- ${LOCALBASE}/share/texmf/tex/latex/ucs/utf8x.def:${PORTSDIR}/print/latex-ucs
-PORTDOCS= *
-.else
-CONFIGURE_ARGS+=--with-doc none
-.endif
-
-.if ${PORT_OPTIONS:MIDE}
-BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-PLIST_SUB+= IDE=""
-MAN1+= coqide.1
-.else
-PLIST_SUB+= IDE="@comment "
-CONFIGURE_ARGS+=--coqide no
-.endif
+CONFIGURE_ARGS= --prefix ${PREFIX} \
+ --mandir ${PREFIX}/man \
+ --emacslib ${PREFIX}/share/emacs/site-lisp \
+ --opt
+MAKE_ENV= COQINSTALLPREFIX=${DESTDIR}
+
+OPTIONS_DEFINE= DOCS IDE
+OPTIONS_DEFAULT= DOCS IDE
+OPTIONS_SUB= yes
+IDE_DESC= Include desktop environment (coqide)
+IDE_BUILD_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+IDE_RUN_DEPENDS= ${IDE_BUILD_DEPENDS
+IDE_CONFIGURE_OFF= --coqide no
+DOCS_USE= TEX=latex:build,dvipsk:build
+DOCS_BUILD_DEPENDS= hevea:${PORTSDIR}/textproc/hevea \
+ ${LOCALBASE}/share/texmf/tex/latex/ucs/utf8x.def:${PORTSDIR}/print/latex-ucs
+DOCS_CONFIGURE_OFF= --with-doc none
+PORTDOCS= *
.include <bsd.port.pre.mk>
@@ -67,6 +52,8 @@ post-patch:
-e '/^MAKE=/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's:/bin/bash:/bin/sh:' \
${WRKSRC}/Makefile* ${WRKSRC}/install.sh
+ @${REINPLACE_CMD} -e '/^#COQINSTALLPREFIX/{s/^#//;s|$$|$${DESTDIR}|;}' \
+ ${WRKSRC}/Makefile.build
@${REINPLACE_CMD} -e '/show_latex_mes/s/)$$/; true)/' ${WRKSRC}/Makefile.doc
.include <bsd.port.post.mk>
diff --git a/math/coq/distinfo b/math/coq/distinfo
index 0f7030900fcf..6bf472a3545e 100644
--- a/math/coq/distinfo
+++ b/math/coq/distinfo
@@ -1,2 +1,2 @@
-SHA256 (coq-8.4pl2.tar.gz) = fb719a38f613b01861e3b251e745a5c8ef395a26ce7029668e85ac75fcbca2d8
-SIZE (coq-8.4pl2.tar.gz) = 4145112
+SHA256 (coq-8.4pl3.tar.gz) = 97583d637f981c5554007f4e99ce6420ebc737186b1d021bd71766fd891cfb38
+SIZE (coq-8.4pl3.tar.gz) = 4064579
diff --git a/math/coq/pkg-plist b/math/coq/pkg-plist
index 19e779952d0d..090299e6907f 100644
--- a/math/coq/pkg-plist
+++ b/math/coq/pkg-plist
@@ -823,7 +823,7 @@ lib/coq/proofs/proofview.cmi
lib/coq/proofs/redexpr.cmi
lib/coq/proofs/refiner.cmi
lib/coq/proofs/tacexpr.cmi
-lib/coq/proofs/tac%%PERL_ARCH%%.cmi
+lib/coq/proofs/tacmach.cmi
lib/coq/proofs/tactic_debug.cmi
lib/coq/proofs/proofs.cmxa
lib/coq/proofs/proofs.a
@@ -950,6 +950,19 @@ lib/coq/libcoqrun.a
%%IDE%%lib/coq/ide/command_windows.cmi
%%IDE%%lib/coq/ide/coqide_ui.cmi
%%IDE%%lib/coq/ide/coqide.cmi
+man/man1/coq-tex.1.gz
+man/man1/coq_makefile.1.gz
+man/man1/coqc.1.gz
+man/man1/coqchk.1.gz
+man/man1/coqdep.1.gz
+man/man1/coqdoc.1.gz
+man/man1/coqide.1.gz
+man/man1/coqmktop.1.gz
+man/man1/coqtop.1.gz
+man/man1/coqtop.byte.1.gz
+man/man1/coqtop.opt.1.gz
+man/man1/coqwc.1.gz
+man/man1/gallina.1.gz
share/emacs/site-lisp/coq-db.el
share/emacs/site-lisp/coq-font-lock.el
share/emacs/site-lisp/coq-syntax.el
@@ -1041,3 +1054,4 @@ share/emacs/site-lisp/coqdoc.sty
@dirrm lib/coq/tools
@dirrm lib/coq
@dirrm etc/xdg/coq
+@dirrmtry etc/xdg