aboutsummaryrefslogtreecommitdiff
path: root/math/dieharder
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-05 03:35:33 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-05 03:35:33 +0000
commitd261caefeec1e0af34a21c857a67cf4c5494029e (patch)
tree39576aa33e9ba8e4b529bc930f5732f36c738b32 /math/dieharder
parent42a7222c78798f26ad027229e8d718cbdc5feb2a (diff)
downloadports-d261caefeec1e0af34a21c857a67cf4c5494029e.tar.gz
ports-d261caefeec1e0af34a21c857a67cf4c5494029e.zip
Notes
Diffstat (limited to 'math/dieharder')
-rw-r--r--math/dieharder/Makefile12
-rw-r--r--math/dieharder/distinfo6
-rw-r--r--math/dieharder/files/patch-dieharder__output.c10
-rw-r--r--math/dieharder/files/patch-dieharder_dieharder.154
-rw-r--r--math/dieharder/files/patch-libdieharder__countx.c10
-rw-r--r--math/dieharder/files/patch-libdieharder__histogram.c10
-rw-r--r--math/dieharder/pkg-plist7
7 files changed, 47 insertions, 62 deletions
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 2d0fa0246ed5..083154fa41bf 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dieharder
-PORTVERSION= 2.28.1
-PORTREVISION= 1
+DISTVERSION= 3.29.4beta
CATEGORIES= math
MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/
EXTRACT_SUFX= .tgz
@@ -17,8 +16,12 @@ COMMENT= A random number generator testsuite
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+MAKE_JOBS_UNSAFE= yes
+
USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:22
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
MAN1= dieharder.1
MAN3= libdieharder.3
@@ -33,4 +36,7 @@ run-autotools:
-e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
${WRKSRC}/configure
+test: build
+ ${WRKSRC}/dieharder/dieharder -a
+
.include <bsd.port.mk>
diff --git a/math/dieharder/distinfo b/math/dieharder/distinfo
index a5479ec2638a..4bcefa347f53 100644
--- a/math/dieharder/distinfo
+++ b/math/dieharder/distinfo
@@ -1,3 +1,3 @@
-MD5 (dieharder-2.28.1.tgz) = 47819cd609648f506a40ec9110c4463c
-SHA256 (dieharder-2.28.1.tgz) = 748ec4716e64de38807e126f10335e45136fa789056e9f647a6bf73698205286
-SIZE (dieharder-2.28.1.tgz) = 766985
+MD5 (dieharder-3.29.4beta.tgz) = eba447e1918d9ef3d70da11f14149a21
+SHA256 (dieharder-3.29.4beta.tgz) = 7bdaf3f942908c5dd3063abd79d8e1ad242b59f6e6bf3f87c0d96434e3e113ff
+SIZE (dieharder-3.29.4beta.tgz) = 995969
diff --git a/math/dieharder/files/patch-dieharder__output.c b/math/dieharder/files/patch-dieharder__output.c
new file mode 100644
index 000000000000..80eca53cb67f
--- /dev/null
+++ b/math/dieharder/files/patch-dieharder__output.c
@@ -0,0 +1,10 @@
+--- dieharder/output.c.orig 2009-12-27 13:32:54.000000000 -0500
++++ dieharder/output.c 2009-12-27 14:32:35.000000000 -0500
+@@ -614,6 +614,7 @@
+ printf("\n");
+ printf("#=============================================================================#\n");
+ fflush(stdout);
++ free(bin);
+
+ }
+
diff --git a/math/dieharder/files/patch-dieharder_dieharder.1 b/math/dieharder/files/patch-dieharder_dieharder.1
deleted file mode 100644
index 7b6380be8e4e..000000000000
--- a/math/dieharder/files/patch-dieharder_dieharder.1
+++ /dev/null
@@ -1,54 +0,0 @@
---- dieharder/dieharder.1.orig 2008-09-08 08:37:19.000000000 -0400
-+++ dieharder/dieharder.1 2008-11-14 20:05:01.794803058 -0500
-@@ -1,6 +1,6 @@
- .\" $Id: dieharder.1 425 2008-08-19 10:01:36Z rgb $
--.TH DieHarder 1 "Copyright 2004 Robert G. Brown" "DieHarder"
-+.TH dieharder 1 "Copyright 2004 Robert G. Brown" "DieHarder"
- .SH NAME
--rand_rate \- A testing and benchmarking tool for GSL random number
-+dieharder \- A testing and benchmarking tool for GSL random number
- generators
-
-@@ -13,5 +13,5 @@
- [-v verbose flag] [-x xvalue] [-y yvalue] [-z zvalue]
-
--.SH DieHarder OPTIONS
-+.SH OPTIONS
-
- .TP
-@@ -40,6 +40,6 @@
- -l list all known tests.
- .TP
---n ntuple - set ntuple length for tests on short bit strings that permit
--the length to be varied (e.g. rgb bitdist).
-+-n ntuple - set ntuple length for tests on short bit strings that
-+permit the length to be varied (e.g. rgb bitdist).
- .TP
- -p count - sets the number of p-value samples per test (default 100).
-@@ -93,5 +93,4 @@
-
- .SH DESCRIPTION
--.B DieHarder
- This is the current snapshot of the dieharder random number
- tester. It encapsulates all of the Gnu Scientific Library random number
-@@ -123,5 +122,5 @@
-
- .SH P-VALUES AND THE NULL HYPOTHESIS
--.B DieHarder returns "p-values". To understand what a p-value is and
-+dieharder returns "p-values". To understand what a p-value is and
- how to use it, it is essential to understand the
- .I null hypothesis.
-@@ -405,5 +404,5 @@
- as prototypes, and can likely be submitted to the GSL for inclusion if
- they pass the tests as well or better than the generators that are already
--there. Dieharder is designed to (ultimately) be a
-+there. dieharder is designed to (ultimately) be a
- .I very convenient tool
- for testing new software RNGs.
-@@ -535,5 +534,5 @@
-
- .SH PUBLICATION RULES
--.B DieHarder
-+dieharder
- is entirely original code and can be modified and used at will by any
- user, provided that:
diff --git a/math/dieharder/files/patch-libdieharder__countx.c b/math/dieharder/files/patch-libdieharder__countx.c
new file mode 100644
index 000000000000..61aba224a498
--- /dev/null
+++ b/math/dieharder/files/patch-libdieharder__countx.c
@@ -0,0 +1,10 @@
+--- libdieharder/countx.c.orig 2009-12-27 13:35:32.000000000 -0500
++++ libdieharder/countx.c 2009-12-27 13:36:18.000000000 -0500
+@@ -219,6 +219,7 @@
+ for (i=0; i<=MAXBITS; ++i) {
+ if (ftab[i] > BUCKETS) {
+ fprintf(stderr, "ftab[%lu]=%lu needs a bigger LOGBUCKETS\n", i, ftab[i]);
++ free(data);
+ return 1;
+ }
+ }
diff --git a/math/dieharder/files/patch-libdieharder__histogram.c b/math/dieharder/files/patch-libdieharder__histogram.c
new file mode 100644
index 000000000000..ededf39bc9d3
--- /dev/null
+++ b/math/dieharder/files/patch-libdieharder__histogram.c
@@ -0,0 +1,10 @@
+--- libdieharder/histogram.c.orig 2009-12-27 13:37:57.000000000 -0500
++++ libdieharder/histogram.c 2009-12-27 14:31:11.000000000 -0500
+@@ -95,6 +95,7 @@
+ for(i=0;i<nbins;i++) printf("%4.1f|",(i+1)*binscale);
+ printf("\n");
+ printf("#==================================================================\n");
++ free(bin);
+
+ }
+
diff --git a/math/dieharder/pkg-plist b/math/dieharder/pkg-plist
index 1533b24eeff1..200cf30f7289 100644
--- a/math/dieharder/pkg-plist
+++ b/math/dieharder/pkg-plist
@@ -20,12 +20,15 @@ include/dieharder/diehard_rank_6x8.h
include/dieharder/diehard_runs.h
include/dieharder/diehard_squeeze.h
include/dieharder/diehard_sums.h
-include/dieharder/dieharder_types.h
+include/dieharder/dieharder_rng_types.h
+include/dieharder/dieharder_test_types.h
include/dieharder/libdieharder.h
include/dieharder/marsaglia_tsang_gcd.h
include/dieharder/marsaglia_tsang_gorilla.h
include/dieharder/parse.h
include/dieharder/rgb_bitdist.h
+include/dieharder/rgb_kstest_test.h
+include/dieharder/rgb_lagged_sums.h
include/dieharder/rgb_lmn.h
include/dieharder/rgb_minimum_distance.h
include/dieharder/rgb_operm.h
@@ -41,5 +44,5 @@ include/dieharder/verbose.h
lib/libdieharder.a
lib/libdieharder.la
lib/libdieharder.so
-lib/libdieharder.so.2
+lib/libdieharder.so.3
@dirrm include/dieharder