aboutsummaryrefslogtreecommitdiff
path: root/math/dieharder
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 19:40:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 19:40:22 +0000
commit5090cd21d581c8a8db0d2ea587c1743f945cbcf5 (patch)
tree0c43d4ed14bd98b149450923564fdcfef7c7f2fb /math/dieharder
parentc258a5dab46386425f291b3912e46221e93e6d47 (diff)
- Unbreak && Fix build
PR: 146579 Submitted by: Lucius Windschuh <lwindschuh@gmail.com> Approved by: bf@ (maintainer)
Notes
Notes: svn path=/head/; revision=255825
Diffstat (limited to 'math/dieharder')
-rw-r--r--math/dieharder/Makefile8
-rw-r--r--math/dieharder/files/patch-libdieharder__skein_block_ref.c16
2 files changed, 19 insertions, 5 deletions
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 3582297a466a..55aee7b307f6 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dieharder
DISTVERSION= 3.29.4beta
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/
EXTRACT_SUFX= .tgz
@@ -19,6 +19,7 @@ LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
MAKE_JOBS_UNSAFE= yes
+USE_DOS2UNIX= yes
USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:22
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,16 +29,13 @@ MAN1= dieharder.1
MAN3= libdieharder.3
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= does not compile on i386, ia64, or sparc64
-.endif
post-patch:
@${REINPLACE_CMD} -e "s|./configure|#./configure|g" \
${WRKSRC}/autogen.sh
run-autotools:
- @(cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${SH} ./autogen.sh)
+ (cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -ifv)
@${REINPLACE_CMD} -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
-e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
${WRKSRC}/configure
diff --git a/math/dieharder/files/patch-libdieharder__skein_block_ref.c b/math/dieharder/files/patch-libdieharder__skein_block_ref.c
new file mode 100644
index 000000000000..3a2afb4dd7eb
--- /dev/null
+++ b/math/dieharder/files/patch-libdieharder__skein_block_ref.c
@@ -0,0 +1,16 @@
+--- libdieharder/skein_block_ref.c.orig 2010-05-16 21:20:59.000000000 -0400
++++ libdieharder/skein_block_ref.c 2010-05-16 21:23:09.000000000 -0400
+@@ -121,6 +121,7 @@
+ while (--blkCnt);
+ }
+
++#ifdef TSC_TIME
+ typedef unsigned long long uint64;
+
+ #if 1
+@@ -139,4 +140,5 @@
+ }
+
+ #endif
++#endif
+