aboutsummaryrefslogtreecommitdiff
path: root/math/digitizer
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-06-10 13:30:16 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-06-10 13:30:16 +0000
commit70780ab94c1046df2580782309a124488a6d5d85 (patch)
treeaf09735c0c50d40e2e82e2453829be39c4abf47b /math/digitizer
parent729244c0d0a241cb60ca6e3c3e3a033a0f17e0cf (diff)
downloadports-70780ab94c1046df2580782309a124488a6d5d85.tar.gz
ports-70780ab94c1046df2580782309a124488a6d5d85.zip
Notes
Diffstat (limited to 'math/digitizer')
-rw-r--r--math/digitizer/Makefile71
-rw-r--r--math/digitizer/distinfo3
-rw-r--r--math/digitizer/pkg-descr6
-rw-r--r--math/digitizer/pkg-plist134
4 files changed, 214 insertions, 0 deletions
diff --git a/math/digitizer/Makefile b/math/digitizer/Makefile
new file mode 100644
index 000000000000..56b31449faa8
--- /dev/null
+++ b/math/digitizer/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: digitizer
+# Date created: 27 May 2006
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= digitizer
+PORTVERSION= 2.14
+CATEGORIES= math graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= digit-src-${PORTVERSION:S/./_/}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Engauge Digitizer - Digitizing software to convert graphs into numbers
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_QT_VER= 3
+QTDIR?= ${X11BASE}
+MAKE_ENV= QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++" \
+ QTDIR="${QTDIR}"
+
+DESKTOP_ENTRIES= "Engauge Digitizer" \
+ "Digitizing software to convert graphs into numbers" \
+ "${DATADIR}/lo16-app-digitizer.png" \
+ "${PORTNAME}" \
+ "Education;Math;" \
+ true
+
+.if !defined(NOPORTDOCS)
+DOCS= README REGRESSION_TESTS
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BROKEN= Does not compile with gcc-2.95
+.endif
+
+pre-configure:
+.if !defined(WITH_DEBUG)
+ ${REINPLACE_CMD} -e '/^CONFIG/s/debug/release/' ${WRKSRC}/digitizer.pro
+.endif
+ ${REINPLACE_CMD} -e 's|Path1("usermanual")|Path1("${DOCSDIR}/usermanual")|' \
+ ${WRKSRC}/src/digitmain.cpp
+
+pre-build:
+ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} qmake -unix digitizer.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/img/lo16-app-digitizer.png \
+ ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/usermanual
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ cd ${WRKSRC}/usermanual && ${FIND} . -type f -depth 1 \
+ -exec ${INSTALL_DATA} {} ${DOCSDIR}/usermanual \;
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${FIND} . -type f -depth 1 \
+ -exec ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/digitizer/distinfo b/math/digitizer/distinfo
new file mode 100644
index 000000000000..1e14a076ae0a
--- /dev/null
+++ b/math/digitizer/distinfo
@@ -0,0 +1,3 @@
+MD5 (digit-src-2_14.tar.gz) = 88afbfeae3466ec30f7ca4dcfe464014
+SHA256 (digit-src-2_14.tar.gz) = 9c881e93cb190be015c25d434ceea541b4817a86e1e3534f112b642393caa3b2
+SIZE (digit-src-2_14.tar.gz) = 6071424
diff --git a/math/digitizer/pkg-descr b/math/digitizer/pkg-descr
new file mode 100644
index 000000000000..b7915c9d8917
--- /dev/null
+++ b/math/digitizer/pkg-descr
@@ -0,0 +1,6 @@
+This open source digitizing software converts an image file showing a graph or
+a map into numbers. The image file can come from a scanner, digital camera or
+screenshot. The numbers can be read on the screen, and written or copied to a
+spreadsheet.
+
+WWW: http://digitizer.sourceforge.net/
diff --git a/math/digitizer/pkg-plist b/math/digitizer/pkg-plist
new file mode 100644
index 000000000000..ff52b787e7c1
--- /dev/null
+++ b/math/digitizer/pkg-plist
@@ -0,0 +1,134 @@
+bin/digitizer
+%%DATADIR%%/lo16-app-digitizer.png
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/REGRESSION_TESTS
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/animation.bmp
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/animation.gif
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answerdiscretizing.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answergridremoval.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answerlinegraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answermap.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answermapconst.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answermeasuring.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answernowindow.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answerother.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answerout.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/answerpointgraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/commandlineoptions.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/contextmenukonqueror.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/contextmenuwindows.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dialogs.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_bad_color_after.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_bad_color_before.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_bad_gray_after.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_bad_gray_before.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_ok_after.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/discretize_ok_before.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcoordsys.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcoordsys1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcurvegeometry.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcurvegeometry1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcurves.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgcurves1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgdiscretize.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgdiscretize1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgexport.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgexport1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlggriddisplay.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlggriddisplay1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlggridremoval.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlggridremoval1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgmeasuregeometry.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgmeasuregeometry1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgmeasures.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgmeasures1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgpointmatch.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgpointmatch1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgsegments.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgsegments1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgsessions.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/dlgsessions.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/fixingaxispoints.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/fixingaxispoints.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/gridremoveafter.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/gridremovebefore.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph10.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph11.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph2.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph3.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph4.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph5.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph6.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph7.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph8.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautolinegraph9.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph10.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph11.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph12.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph13.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph2.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph3.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph4.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph5.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph6.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph7.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph8.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutorautopointgraph9.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph2.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph3.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph4.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph5.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph6.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph7.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanlinegraph8.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap2.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap3.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap4.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap5.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap6.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanmap7.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph.html
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph1.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph2.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph3.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph4.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph5.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph6.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph7.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/tutormanpointgraph8.png
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/windowscontexta.jpg
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/windowscontextb.jpg
+%%PORTDOCS%%%%DOCSDIR%%/usermanual/windowscontextc.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/corners.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/gridlines.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/gridlines_log.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/inverse.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/inverse.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/linlog.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/linlog.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/loglin.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/loglog.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/normdist.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/normdist.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/pointplot.bmp
+%%PORTDOCS%%%%EXAMPLESDIR%%/polarplot.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/polarplot.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/testcase.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/testcase.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/testcoords.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/testcoords.sxd
+%%PORTDOCS%%%%EXAMPLESDIR%%/usgs.png
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/usermanual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%