aboutsummaryrefslogtreecommitdiff
path: root/math/djbfft
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-13 22:59:18 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-13 22:59:18 +0000
commit9d4aff5be1169b8a19a339a09f2b1e284da79a13 (patch)
treefce0cce3f2ec19d51e17e28513144000f707d60c /math/djbfft
parent185e9e94170c372218fe02b75fd2a497a77162b5 (diff)
downloadports-9d4aff5be1169b8a19a339a09f2b1e284da79a13.tar.gz
ports-9d4aff5be1169b8a19a339a09f2b1e284da79a13.zip
Notes
Diffstat (limited to 'math/djbfft')
-rw-r--r--math/djbfft/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/math/djbfft/Makefile b/math/djbfft/Makefile
index efb534706423..a3a840d2fb7d 100644
--- a/math/djbfft/Makefile
+++ b/math/djbfft/Makefile
@@ -7,6 +7,7 @@
PORTNAME= djbfft
PORTVERSION= 0.76
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://cr.yp.to/djbfft/
@@ -15,13 +16,15 @@ COMMENT= An extremely fast library for floating-point convolution
NO_PACKAGE= Forbidden - we have patches to the distribution.
-BROKEN= "Changes permissions on /usr/local and /usr/local/lib"
-
DISABLE_SIZE= yes
ALL_TARGET=
INSTALL_TARGET=setup check
USE_PERL5_BUILD=yes
+HEADER_FILES= complex4.h complex8.h fftc4.h fftc8.h fftfreq.h \
+ fftr4.h fftr8.h real4.h real8.h
+LIB_FILES= libdjbfft.a
+
post-patch:
@${FIND} ${WRKSRC} -type f -exec \
${PERL} -pi -e 's!(djbfft.a)!lib\1!' {} \;
@@ -44,6 +47,14 @@ do-configure:
pre-install:
@${MKDIR} ${PREFIX}/include/${PORTNAME}
+do-install:
+.for file in ${HEADER_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${LOCALBASE}/include/${PORTNAME}
+.endfor
+.for file in ${LIB_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${LOCALBASE}/lib
+.endfor
+
.include <bsd.port.pre.mk>
pre-everything::