aboutsummaryrefslogtreecommitdiff
path: root/math/dune-foamgrid
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:06:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-17 07:06:16 +0000
commit88365273b1368593f80dc4f15a77ac2b4719126c (patch)
tree4452aeb6ca6bfc261290d05cb1d8c370ae619a59 /math/dune-foamgrid
parentb835409a4d0bc7fbfb3f2b5ab31c5a536e6a0683 (diff)
Notes
Diffstat (limited to 'math/dune-foamgrid')
-rw-r--r--math/dune-foamgrid/Makefile36
-rw-r--r--math/dune-foamgrid/distinfo3
-rw-r--r--math/dune-foamgrid/files/patch-CMakeLists.txt12
-rw-r--r--math/dune-foamgrid/pkg-descr9
-rw-r--r--math/dune-foamgrid/pkg-plist24
5 files changed, 84 insertions, 0 deletions
diff --git a/math/dune-foamgrid/Makefile b/math/dune-foamgrid/Makefile
new file mode 100644
index 000000000000..c3f83450b2a9
--- /dev/null
+++ b/math/dune-foamgrid/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= dune-foamgrid
+DISTVERSION= g20200106
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: one- and two-dimensional simplex grids
+
+LICENSE= GPLv2+
+
+HPP_DEPENDS= dune-common>0:math/dune-common \
+ dune-geometry>0:math/dune-geometry \
+ dune-grid>0:math/dune-grid
+BUILD_DEPENDS= ${HPP_DEPENDS}
+RUN_DEPENDS= ${HPP_DEPENDS}
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= d49187be4940227c945ced02f8457ccc9d47536a
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/math/dune-foamgrid/distinfo b/math/dune-foamgrid/distinfo
new file mode 100644
index 000000000000..73df9e9bf224
--- /dev/null
+++ b/math/dune-foamgrid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610865947
+SHA256 (extensions-dune-foamgrid-d49187be4940227c945ced02f8457ccc9d47536a_GL0.tar.gz) = 8ea74fbabb4d5ee42567bfd056141bd6a5c0c96e76bd3b5555f012b273313fcb
+SIZE (extensions-dune-foamgrid-d49187be4940227c945ced02f8457ccc9d47536a_GL0.tar.gz) = 60403
diff --git a/math/dune-foamgrid/files/patch-CMakeLists.txt b/math/dune-foamgrid/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..6b745f4d165b
--- /dev/null
+++ b/math/dune-foamgrid/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2021-01-17 06:47:55 UTC
++++ CMakeLists.txt
+@@ -20,7 +20,9 @@ dune_project()
+ dune_enable_all_packages()
+
+ add_subdirectory(dune)
++if (FREEBSD_INSTALL_DOCS)
+ add_subdirectory(doc)
++endif()
+ add_subdirectory(cmake/modules)
+ add_subdirectory(examples EXCLUDE_FROM_ALL)
+ if (dune-python_FOUND)
diff --git a/math/dune-foamgrid/pkg-descr b/math/dune-foamgrid/pkg-descr
new file mode 100644
index 000000000000..e50cf6f9862a
--- /dev/null
+++ b/math/dune-foamgrid/pkg-descr
@@ -0,0 +1,9 @@
+dune-foamgrid is a module of the DUNE Numerics framework for solving partial
+differential equations (PDEs) with grid-based methods.
+
+dune-foamgrid implements one- and two-dimensional simplex grids, which can be
+embedded in Euclidean spaces of arbitrary dimension. As a special feature,
+FoamGrid does not require the grids to be manifolds and grid can add/remove
+elements art run-time.
+
+WWW: https://www.dune-project.org/
diff --git a/math/dune-foamgrid/pkg-plist b/math/dune-foamgrid/pkg-plist
new file mode 100644
index 000000000000..664b7b7b9ef9
--- /dev/null
+++ b/math/dune-foamgrid/pkg-plist
@@ -0,0 +1,24 @@
+include/dune/foamgrid/dgffoam.cc
+include/dune/foamgrid/dgffoam.hh
+include/dune/foamgrid/foamgrid.hh
+include/dune/foamgrid/foamgrid/foamgrid.cc
+include/dune/foamgrid/foamgrid/foamgridedge.hh
+include/dune/foamgrid/foamgrid/foamgridelements.hh
+include/dune/foamgrid/foamgrid/foamgridentity.hh
+include/dune/foamgrid/foamgrid/foamgridentitypointer.hh
+include/dune/foamgrid/foamgrid/foamgridentityseed.hh
+include/dune/foamgrid/foamgrid/foamgridfactory.hh
+include/dune/foamgrid/foamgrid/foamgridgeometry.hh
+include/dune/foamgrid/foamgrid/foamgridhierarchiciterator.hh
+include/dune/foamgrid/foamgrid/foamgridindexsets.hh
+include/dune/foamgrid/foamgrid/foamgridintersectioniterators.hh
+include/dune/foamgrid/foamgrid/foamgridintersections.hh
+include/dune/foamgrid/foamgrid/foamgridleafiterator.hh
+include/dune/foamgrid/foamgrid/foamgridleveliterator.hh
+include/dune/foamgrid/foamgrid/foamgridnulliteratorfactory.hh
+include/dune/foamgrid/foamgrid/foamgridvertex.hh
+lib/cmake/dune-foamgrid/dune-foamgrid-config-version.cmake
+lib/cmake/dune-foamgrid/dune-foamgrid-config.cmake
+lib/dunecontrol/dune-foamgrid/dune.module
+libdata/pkgconfig/dune-foamgrid.pc
+share/dune/cmake/modules/DuneFoamgridMacros.cmake