aboutsummaryrefslogtreecommitdiff
path: root/math/dune-spgrid/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-15 20:05:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-15 20:05:38 +0000
commit59eb42e57befebdce93b5a0555f96a5e5fd5f248 (patch)
tree24c969990d91af5c43f0b461d9f860c70359bb8e /math/dune-spgrid/Makefile
parent1dad567b3203731cdf6c3ed1efa09aae7f0cfbb1 (diff)
downloadports-59eb42e57befebdce93b5a0555f96a5e5fd5f248.tar.gz
ports-59eb42e57befebdce93b5a0555f96a5e5fd5f248.zip
Notes
Diffstat (limited to 'math/dune-spgrid/Makefile')
-rw-r--r--math/dune-spgrid/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/dune-spgrid/Makefile b/math/dune-spgrid/Makefile
new file mode 100644
index 000000000000..9febd761789f
--- /dev/null
+++ b/math/dune-spgrid/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= dune-spgrid
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6.0rc1.20200105
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: A structured, parallel DUNE grid implementation
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+DUNE_DEPENDS= dune-common>0:math/dune-common \
+ dune-grid>0:math/dune-grid \
+ dune-geometry>0:math/dune-geometry
+BUILD_DEPENDS= ${DUNE_DEPENDS} \
+ openmpi>0:net/openmpi \
+ vc>0:devel/vc
+RUN_DEPENDS= ${DUNE_DEPENDS}
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= 3977013bee93d1b113b155cc5b881d28d3ee37f5
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>