aboutsummaryrefslogtreecommitdiff
path: root/math/elmer-umfpack/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:47:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:47:52 +0000
commit662486c37e9e3dadb782b011ee4f12bce66f5a34 (patch)
tree5e688c4622e02247c507e935980b3059df4d817e /math/elmer-umfpack/Makefile
parentd3f1f4d41271509ffa43b7e5d34fc2e4855b1047 (diff)
Notes
Diffstat (limited to 'math/elmer-umfpack/Makefile')
-rw-r--r--math/elmer-umfpack/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/math/elmer-umfpack/Makefile b/math/elmer-umfpack/Makefile
new file mode 100644
index 000000000000..ede2e594dca5
--- /dev/null
+++ b/math/elmer-umfpack/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: elmer-umfpack
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= umfpack
+PORTVERSION= 4.4a
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= UMFPACK library used by ELMER FEM package
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran
+
+CONFLICTS= umfpack-[0-9].[0-9]*
+
+USE_GCC= 4.1+
+WITH_FORTRAN= yes
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+CONFIGURE_ENV+= FC=${FC} F77=${FC}
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+# This should be looked up by autoconf
+CFLAGS+= -DGETRUSAGE
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+.include <bsd.port.post.mk>