aboutsummaryrefslogtreecommitdiff
path: root/math/ent/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-07-28 20:37:23 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-07-28 20:37:23 +0000
commit66e327d6b8a586326f88ffd96119680e25cd0e14 (patch)
tree00f353e37276f712245f558dbffd7284352f764d /math/ent/Makefile
parentdf7dc9be0a8e323109cd79059e07b946d56765c9 (diff)
downloadports-66e327d6b8a586326f88ffd96119680e25cd0e14.tar.gz
ports-66e327d6b8a586326f88ffd96119680e25cd0e14.zip
Notes
Diffstat (limited to 'math/ent/Makefile')
-rw-r--r--math/ent/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/ent/Makefile b/math/ent/Makefile
new file mode 100644
index 000000000000..853c540c03bb
--- /dev/null
+++ b/math/ent/Makefile
@@ -0,0 +1,29 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= ent
+PORTVERSION= 0.20080128
+CATEGORIES= math
+MASTER_SITES= http://www.fourmilab.ch/random/
+DISTNAME= random
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= Entropy calculation and analysis of putative random sequences
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+ALL_TARGET= ent
+PLIST_FILES= bin/ent
+
+regression-test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+
+post-patch:
+ ${REINPLACE_CMD} -e '/CC = /d' -e '/CFLAGS = /s,$$, ${CFLAGS},' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ent ${PREFIX}/bin
+
+.include <bsd.port.mk>