aboutsummaryrefslogtreecommitdiff
path: root/math/ent/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-18 14:58:23 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-18 14:58:23 +0000
commiteff58e73b2e690c8b2bdf42b79a2ca6c1ce2ee36 (patch)
tree436308847be77e342aa805b554c059fe719ba85d /math/ent/Makefile
parent3b55b2d6d36aad565cc0d0bab6d1dce9e3b2db57 (diff)
downloadports-eff58e73b2e690c8b2bdf42b79a2ca6c1ce2ee36.tar.gz
ports-eff58e73b2e690c8b2bdf42b79a2ca6c1ce2ee36.zip
Notes
Diffstat (limited to 'math/ent/Makefile')
-rw-r--r--math/ent/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/math/ent/Makefile b/math/ent/Makefile
index 2c834686e1c2..197e26c6d951 100644
--- a/math/ent/Makefile
+++ b/math/ent/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ent
PORTVERSION= 0.20080128
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.fourmilab.ch/random/
DISTNAME= random
@@ -11,19 +12,30 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= horia@racoviceanu.com
COMMENT= Entropy calculation and analysis of putative random sequences
-USES= zip
+USES= compiler zip
NO_WRKSUBDIR= yes
ALL_TARGET= ent
PLIST_FILES= bin/ent
+PORTDOCS= ent.html entitle.gif
+OPTIONS_DEFINE= DOCS
+
regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+.include <bsd.port.pre.mk>
+
post-patch:
- ${REINPLACE_CMD} -e '/CC = /d' -e '/CFLAGS = /s,$$, ${CFLAGS},' \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|; s|^CFLAGS |&+|' ${WRKSRC}/Makefile
+
+.if ${COMPILER_TYPE} == clang
+ ${REINPLACE_CMD} -e 's|-g ||' ${WRKSRC}/Makefile
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>