aboutsummaryrefslogtreecommitdiff
path: root/math/fann/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2012-03-31 07:50:36 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2012-03-31 07:50:36 +0000
commit6cb90ab37d055f39171d80dc7d100d37fa23decb (patch)
tree3dbd44d5d26f630052ca041453d7f370694b92a5 /math/fann/Makefile
parente8c92c9ef837587311a97892a179c9ed847e1323 (diff)
Notes
Diffstat (limited to 'math/fann/Makefile')
-rw-r--r--math/fann/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/math/fann/Makefile b/math/fann/Makefile
index cf8dda3afd24..9ea7d07a8786 100644
--- a/math/fann/Makefile
+++ b/math/fann/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= fann
-PORTVERSION= 2.1.0b
+PORTVERSION= 2.2.0
CATEGORIES= math science
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}eta
-DISTNAME= fann-2.1.0beta
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= FANN-2.2.0-Source
MAINTAINER= tzhuan@csie.org
COMMENT= A free open source neural network library
-WRKSRC= ${WRKDIR}/fann-2.1.0
+WRKSRC= ${WRKDIR}/FANN-2.2.0-Source
+
+USE_CMAKE= yes
USE_ZIP= yes
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+post-patch:
+ ${REINPLACE_CMD} -e 's|/lib/pkgconfig|/libdata/pkgconfig|g' ${WRKSRC}/CMakeLists.txt
+
+post-configure:
+ ${ENV} CPP=${CPP} CC=${CC} CXX=${CXX} ${CMAKE_BIN} ${WRKSRC} -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
.include <bsd.port.mk>