aboutsummaryrefslogtreecommitdiff
path: root/math/femlab
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-03-31 02:27:33 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-03-31 02:27:33 +0000
commit009803615e9d0762ada7664bd100f30d0b00bd0a (patch)
tree1b2faa07230ea8ec5a6e05799a035e6b54529f28 /math/femlab
parent0086d43620fb2f979d654fa641084d366169cc80 (diff)
downloadports-009803615e9d0762ada7664bd100f30d0b00bd0a.tar.gz
ports-009803615e9d0762ada7664bd100f30d0b00bd0a.zip
Notes
Diffstat (limited to 'math/femlab')
-rw-r--r--math/femlab/Makefile7
-rw-r--r--math/femlab/files/patch-ab14
2 files changed, 7 insertions, 14 deletions
diff --git a/math/femlab/Makefile b/math/femlab/Makefile
index 65cd34167c5c..a159f8085c10 100644
--- a/math/femlab/Makefile
+++ b/math/femlab/Makefile
@@ -20,6 +20,13 @@ USE_X_PREFIX= yes
FEMLAB_HOME= ${PREFIX}/lib/X11/femlab
+pre-patch:
+ @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ ${WRKSRC}/source/graph.c ${WRKSRC}/source/y.tab.c \
+ ${WRKSRC}/source/newdata.c ${WRKSRC}/source/post.c \
+ ${WRKSRC}/source/kraftwerk.c ${WRKSRC}/source/list.c \
+ ${WRKSRC}/include/xv.h ${WRKSRC}/fsource/y.tab.c
+
do-install:
${MKDIR} ${FEMLAB_HOME}/bin
${INSTALL_PROGRAM} ${WRKSRC}/source/femlab ${FEMLAB_HOME}/bin
diff --git a/math/femlab/files/patch-ab b/math/femlab/files/patch-ab
index 5c3bc76ecc41..c67482259225 100644
--- a/math/femlab/files/patch-ab
+++ b/math/femlab/files/patch-ab
@@ -1,20 +1,6 @@
*** source/graph.c.orig Thu Sep 14 08:42:13 1995
--- source/graph.c Sat Mar 7 00:14:42 1998
***************
-*** 14,21 ****
---- 14,24 ----
- */
-
- #include <stdio.h>
-+ #ifdef __STDC__
- #include <stdlib.h>
-+ #else
- #include <malloc.h>
-+ #endif
- #include <math.h>
-
-
-***************
*** 608,614 ****
void getDrawingScale()
{