aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-18 10:48:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-18 10:48:23 +0000
commita9433bf853ad68cad861698eccd9ad66cd1e429b (patch)
tree5b89d3601f6921792e23070bb489eaa319c9259c /math/fftw3/Makefile
parentef5cd63aba3d993c5b577b759acc16ccd982f11f (diff)
Notes
Diffstat (limited to 'math/fftw3/Makefile')
-rw-r--r--math/fftw3/Makefile41
1 files changed, 26 insertions, 15 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index b0932029fea0..1c568e3223a0 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -5,38 +5,49 @@
# $FreeBSD$
#
-PORTNAME= fftw
-PORTVERSION= 2.1.5
-PORTREVISION= 2
+PORTNAME= fftw3
+PORTVERSION= 3.0.1
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/ \
ftp://theory.lcs.mit.edu/pub/fftw/ \
ftp://pm.cse.rmit.edu.au/pub/dsp/fftw/
+DISTNAME= fftw-${PORTVERSION}
-MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+MAINTAINER= ahze@ahze.net
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
USE_LIBTOOL_VER=13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --enable-shared
+USE_GNOME= gnomehack gnomeprefix gnometarget lthack pkgconfig
INSTALLS_SHLIB= yes
+MAN1= fftw-wisdom-to-conf.1 fftw-wisdom.1
+INFO= fftw3
+
+CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
+ OPTIMIZED_ATHLON "Enable AMD K7(Athlon) optimizations" off \
+ SMP_THREADS "Enable FFTW SMP threads library" off
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --enable-i386-hacks
+.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITH_OPTIMIZED_ATHLON)
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -O2 -ffast-math -fomit-frame-pointer"
.endif
-post-extract:
- @${RM} ${WRKSRC}/doc/fftw.info*
+.if defined(WITH_OPTIMIZED_ATHLON)
+CONFIGURE_ARGS+=--enable-k7
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -O3 -fomit-frame-pointer -fno-schedule-insns \
+ -malign-double -fstrict-aliasing -mpreferred-stack-boundary=4 \
+ -ffast-math"
+.endif
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/fftw.ps ${DOCSDIR}
+.if defined(WITH_SMP_THREADS)
+CONFIGURE_ARGS+=--enable-threads
.endif
.include <bsd.port.post.mk>