aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-03-03 09:06:17 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-03-03 09:06:17 +0000
commitd6760b35c7c0e273ab4288261c0195494a72c7ec (patch)
tree7d8655bb4566d59745a3a1a6f76e8ac0e441c449 /math/fftw3
parent41865d308cd29855939a2cf4f7f359e2c929d84e (diff)
downloadports-d6760b35c7c0e273ab4288261c0195494a72c7ec.tar.gz
ports-d6760b35c7c0e273ab4288261c0195494a72c7ec.zip
Notes
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile18
-rw-r--r--math/fftw3/distinfo4
-rw-r--r--math/fftw3/pkg-plist2
3 files changed, 15 insertions, 9 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 6a7899696b14..49fd67bd9a5c 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -6,8 +6,8 @@
# $MCom: ports-experimental/math/fftw3/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
PORTNAME= fftw3
-PORTVERSION= 3.3
-PORTREVISION?= 1
+PORTVERSION= 3.3.1
+PORTREVISION?= 0
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/
@@ -17,7 +17,7 @@ DISTNAME= fftw-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT?= Fast C routines to compute the Discrete Fourier Transform
-# current flavors: default, float, and long
+#current flavors: default, float, long, and quad
FFTW3_FLAVOR?= default
FFTW3_SUFX=
@@ -65,18 +65,22 @@ CFLAGS+= -malign-double
WITHOUT_NO_STRICT_ALIASING= yes
.endif # end WITH_OPTIMIZED_CFLAGS
+#Users must add altivec and avx to MACHINE_CPU when desired:
+#this is not currently done in bsd.cpu.mk
.if ${FFTW3_FLAVOR} == "default"
-. if !empty(MACHINE_CPU:Msse2)
+. if !empty(MACHINE_CPU:Mavx)
+CONFIGURE_ARGS+=--enable-avx
+. elif !empty(MACHINE_CPU:Msse2)
CONFIGURE_ARGS+=--enable-sse2
. endif
.elif ${FFTW3_FLAVOR} == "float"
FFTW3_SUFX= f
FFTW3_PKGNAMESUFFIX= -float
CONFIGURE_ARGS+=--enable-float
-. if !empty(MACHINE_CPU:Msse)
+. if !empty(MACHINE_CPU:Mavx)
+CONFIGURE_ARGS+=--enable-avx
+. elif !empty(MACHINE_CPU:Msse)
CONFIGURE_ARGS+=--enable-sse
-#Unfortunately, the user must add altivec to MACHINE_CPU when desired,
-#because this is not currently done in bsd.cpu.mk
. elif !empty(ARCH:Mpowerpc*) && !empty(MACHINE_CPU:Maltivec)
CONFIGURE_ARGS+=--enable-altivec
. endif
diff --git a/math/fftw3/distinfo b/math/fftw3/distinfo
index c8b925f8fb69..b95c136fb6ee 100644
--- a/math/fftw3/distinfo
+++ b/math/fftw3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fftw-3.3.tar.gz) = d25a98521a13933e678ce19319d03ddc915826764e1e59abd12d172c239b6aea
-SIZE (fftw-3.3.tar.gz) = 3965713
+SHA256 (fftw-3.3.1.tar.gz) = c77fc5cda6ce868857aa565cb9b0df0d7a4fcf388ce5c6d482acd80e2452b739
+SIZE (fftw-3.3.1.tar.gz) = 4039988
diff --git a/math/fftw3/pkg-plist b/math/fftw3/pkg-plist
index aa24cce38313..012e6f6358ca 100644
--- a/math/fftw3/pkg-plist
+++ b/math/fftw3/pkg-plist
@@ -3,6 +3,8 @@ bin/fftw%%FFTW3_SUFX%%-wisdom
%%DEF%%include/fftw3.f
%%DEF%%include/fftw3.f03
%%DEF%%include/fftw3.h
+%%DEF%%include/fftw3l.f03
+%%DEF%%include/fftw3q.f03
lib/libfftw3%%FFTW3_SUFX%%.a
lib/libfftw3%%FFTW3_SUFX%%.la
lib/libfftw3%%FFTW3_SUFX%%.so