aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-12-09 21:58:18 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-12-09 21:58:18 +0000
commitc4e25c84d95491fe0326153838942052f291f7c8 (patch)
tree4e0d483035aed90cfd8eb5a07d08b40b0efd689e /math/fftw3
parent21ee7168bce3d52a5cbdecc9d29e855fcead4532 (diff)
downloadports-c4e25c84d95491fe0326153838942052f291f7c8.tar.gz
ports-c4e25c84d95491fe0326153838942052f291f7c8.zip
Notes
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 04ab626d681d..dd7b2510c054 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -44,17 +44,16 @@ INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
SMP_THREADS "Enable FFTW SMP threads library" off \
- OPTIMIZED_ATHLON "Enable AMD Athlon/3dNow! optimizations" off \
SSE "Enable SSE optimized routines" off
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITH_OPTIMIZED_ATHLON)
+.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer"
.endif
.if ${ARCH}=="i386"
-.if defined(WITH_OPTIMIZED_ATHLON)
+.if ${MACHINE_CPU:M3dnow}
CONFIGURE_ARGS+=--enable-k7
CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
-malign-double -fstrict-aliasing -mpreferred-stack-boundary=4 \