aboutsummaryrefslogtreecommitdiff
path: root/math/fityk/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 15:24:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 15:24:22 +0000
commitff09caef8f4073cf0b967a126496e01f6c558cf5 (patch)
treeeb9c9145aa960303ff6567de9e4dd9b0240d5130 /math/fityk/Makefile
parent7f450d3818a293b3d287a710a830cc410f606c06 (diff)
downloadports-ff09caef8f4073cf0b967a126496e01f6c558cf5.tar.gz
ports-ff09caef8f4073cf0b967a126496e01f6c558cf5.zip
Notes
Diffstat (limited to 'math/fityk/Makefile')
-rw-r--r--math/fityk/Makefile57
1 files changed, 44 insertions, 13 deletions
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 05bdd8f2458d..72f7dee3e7a5 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -7,27 +7,58 @@
#
PORTNAME= fityk
-PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTVERSION= 0.5.0.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}p${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free peak fitting software
-BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24 \
- readline.5:${PORTSDIR}/devel/readline
+BUILD_DEPENDS= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost \
+ gnuplot:${PORTSDIR}/math/gnuplot
+RUN_DEPENDS= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost \
+ gnuplot:${PORTSDIR}/math/gnuplot
-USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
-CPPFLAGS+= "-I${LOCALBASE}/include"
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-optimization --with-wx-config=wxgtk2-2.4-config
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+
+USE_GNOME= gnometarget gtk20
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= fityk.1
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500018
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
+.endif
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CFLAGS+= -fpermissive
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
+LDFLAGS+= -lstlport_gcc
+.endif
+
+.if defined(WITH_WXGTK24)
+LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
+CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.4-config
+.else
+LIB_DEPENDS+= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
+CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+.endif
-MAN1= fityk.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CPPFLAGS=|#CPPFLAGS=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|config 3rdparty|config|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>