aboutsummaryrefslogtreecommitdiff
path: root/math/fplll
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-08 08:30:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-08 08:30:21 +0000
commit39abbdff9949fbbe05380e05d69052df3987da34 (patch)
tree1dcdc400e3ee6cb57e4d6c40c9cb8921c088e8d7 /math/fplll
parent37da772eb4662c70e36e55e747e7b1c9403702f4 (diff)
downloadports-39abbdff9949fbbe05380e05d69052df3987da34.tar.gz
ports-39abbdff9949fbbe05380e05d69052df3987da34.zip
Notes
Diffstat (limited to 'math/fplll')
-rw-r--r--math/fplll/Makefile23
-rw-r--r--math/fplll/distinfo3
-rw-r--r--math/fplll/pkg-descr16
-rw-r--r--math/fplll/pkg-plist52
4 files changed, 94 insertions, 0 deletions
diff --git a/math/fplll/Makefile b/math/fplll/Makefile
new file mode 100644
index 000000000000..dc30dd8be235
--- /dev/null
+++ b/math/fplll/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= fplll
+DISTVERSION= 5.2.1-229
+DISTVERSIONSUFFIX= -ga8cb572
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lattice algorithms using floating-point arithmetic
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= autoreconf gmake libtool localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/fplll/distinfo b/math/fplll/distinfo
new file mode 100644
index 000000000000..0680ac1e1de0
--- /dev/null
+++ b/math/fplll/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544257080
+SHA256 (fplll-fplll-5.2.1-229-ga8cb572_GH0.tar.gz) = dbeeea014f0c73ff74d25a8ae0a2d7628b98e815f34e27748443e5ff6d087305
+SIZE (fplll-fplll-5.2.1-229-ga8cb572_GH0.tar.gz) = 998853
diff --git a/math/fplll/pkg-descr b/math/fplll/pkg-descr
new file mode 100644
index 000000000000..aacd1b25ee2e
--- /dev/null
+++ b/math/fplll/pkg-descr
@@ -0,0 +1,16 @@
+fplll contains implementations of several lattice algorithms. The implementation
+relies on floating-point orthogonalization, and LLL is central to the code,
+hence the name.
+
+It includes implementations of floating-point LLL reduction algorithms, offering
+different speed/guarantees ratios. It contains a 'wrapper' choosing the
+estimated best sequence of variants in order to provide a guaranteed output as
+fast as possible. In the case of the wrapper, the succession of variants is
+oblivious to the user.
+
+It includes an implementation of the BKZ reduction algorithm, including the
+BKZ-2.0 improvements (extreme enumeration pruning, pre-processing of blocks,
+early termination). Additionally, Slide reduction and self dual BKZ are
+supported.
+
+WWW: https://github.com/fplll/fplll
diff --git a/math/fplll/pkg-plist b/math/fplll/pkg-plist
new file mode 100644
index 000000000000..52aa643fc922
--- /dev/null
+++ b/math/fplll/pkg-plist
@@ -0,0 +1,52 @@
+bin/fplll
+bin/latsieve
+bin/latticegen
+include/fplll.h
+include/fplll/bkz.h
+include/fplll/bkz_param.h
+include/fplll/defs.h
+include/fplll/enum/enumerate.h
+include/fplll/enum/enumerate_base.h
+include/fplll/enum/enumerate_ext.h
+include/fplll/enum/evaluator.h
+include/fplll/fplll.h
+include/fplll/fplll_config.h
+include/fplll/gso.h
+include/fplll/gso_gram.h
+include/fplll/gso_interface.h
+include/fplll/hlll.h
+include/fplll/householder.h
+include/fplll/lll.h
+include/fplll/nr/dpe.h
+include/fplll/nr/matrix.cpp
+include/fplll/nr/matrix.h
+include/fplll/nr/nr.h
+include/fplll/nr/nr_FP.inl
+include/fplll/nr/nr_FP_d.inl
+include/fplll/nr/nr_FP_dd.inl
+include/fplll/nr/nr_FP_dpe.inl
+include/fplll/nr/nr_FP_ld.inl
+include/fplll/nr/nr_FP_misc.inl
+include/fplll/nr/nr_FP_mpfr.inl
+include/fplll/nr/nr_FP_qd.inl
+include/fplll/nr/nr_Z.inl
+include/fplll/nr/nr_Z_d.inl
+include/fplll/nr/nr_Z_l.inl
+include/fplll/nr/nr_Z_misc.inl
+include/fplll/nr/nr_Z_mpz.inl
+include/fplll/nr/nr_rand.inl
+include/fplll/nr/numvect.h
+include/fplll/pruner/pruner.h
+include/fplll/pruner/pruner_simplex.h
+include/fplll/sieve/sampler_basic.h
+include/fplll/sieve/sieve_common.h
+include/fplll/sieve/sieve_gauss.h
+include/fplll/sieve/sieve_gauss_str.h
+include/fplll/svpcvp.h
+include/fplll/util.h
+include/fplll/wrapper.h
+lib/libfplll.so
+lib/libfplll.so.5
+lib/libfplll.so.5.0.0
+libdata/pkgconfig/fplll.pc
+%%DATADIR%%/strategies/default.json