aboutsummaryrefslogtreecommitdiff
path: root/math/freefem++
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-29 17:03:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-29 17:03:13 +0000
commitd28ae29053f3467fd6f772c0879ef1dd9279ccd6 (patch)
tree764c5a83bcb89722d46608a7238a842c1b1af3aa /math/freefem++
parent55afd6a9f95010aa5a2a3eaf2724c0fc63aa0240 (diff)
downloadports-d28ae29053f3467fd6f772c0879ef1dd9279ccd6.tar.gz
ports-d28ae29053f3467fd6f772c0879ef1dd9279ccd6.zip
Notes
Diffstat (limited to 'math/freefem++')
-rw-r--r--math/freefem++/Makefile4
-rw-r--r--math/freefem++/files/patch-src::AnyType.hpp12
2 files changed, 12 insertions, 4 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 16883ca42f05..649f24dcb3c1 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -30,10 +30,6 @@ DOCS= BUGS COPYRIGHT HISTORY README DOC/manual.pdf
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on alpha 5.x"
-.endif
-
.if ${OSVERSION} < 501103
USE_GCC= 3.2
.endif
diff --git a/math/freefem++/files/patch-src::AnyType.hpp b/math/freefem++/files/patch-src::AnyType.hpp
new file mode 100644
index 000000000000..1b26f3907ef5
--- /dev/null
+++ b/math/freefem++/files/patch-src::AnyType.hpp
@@ -0,0 +1,12 @@
+--- ./src/AnyType.hpp.orig Sat May 31 11:53:05 2003
++++ ./src/AnyType.hpp Sun Feb 29 16:13:27 2004
+@@ -5,7 +5,8 @@
+ class basicForEachType;
+ typedef const basicForEachType * aType;
+
+-typedef unsigned char AnyData[24];
++//typedef unsigned char AnyData[24];
++typedef unsigned char AnyData[2*(sizeof(void*)+2*sizeof(double))];
+
+ extern map<const string,basicForEachType *> map_type;
+