aboutsummaryrefslogtreecommitdiff
path: root/math/freemat/files
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-12-09 01:07:44 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-12-09 01:07:44 +0000
commitf981519dfa39a92e1e9fd04e73baf65a670dc3b4 (patch)
tree3d113bf5016f08ecba15be50de2adfa0c6b322fd /math/freemat/files
parent97e832746ee69404f2a8423c6dfb75cf26abfca4 (diff)
downloadports-f981519dfa39a92e1e9fd04e73baf65a670dc3b4.tar.gz
ports-f981519dfa39a92e1e9fd04e73baf65a670dc3b4.zip
Notes
Diffstat (limited to 'math/freemat/files')
-rw-r--r--math/freemat/files/patch-CMakeLists.txt20
-rw-r--r--math/freemat/files/patch-configure11
-rw-r--r--math/freemat/files/patch-libs__libFN__CMakeLists.txt15
-rw-r--r--math/freemat/files/patch-libs__libFN__FNFun.cpp17
-rw-r--r--math/freemat/files/patch-libs__libFN__fdlibm.h17
-rw-r--r--math/freemat/files/patch-libs_libCore_MatIO.hpp10
-rw-r--r--math/freemat/files/patch-libs_libFN_FNFun.cpp18
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_Array.cpp11
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_IEEEFP.cpp10
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_Malloc.cpp10
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_Scanner.cpp10
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_Scope.hpp10
-rw-r--r--math/freemat/files/patch-libs_libFreeMat_Token.cpp10
-rw-r--r--math/freemat/files/patch-libs_libGraphics_HandleAxis.cpp13
14 files changed, 69 insertions, 113 deletions
diff --git a/math/freemat/files/patch-CMakeLists.txt b/math/freemat/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..def3f6b672a3
--- /dev/null
+++ b/math/freemat/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- ./CMakeLists.txt.orig 2009-11-13 18:28:43.000000000 -0500
++++ ./CMakeLists.txt 2009-11-13 19:28:04.000000000 -0500
+@@ -217,7 +217,7 @@
+ INCLUDE_DIRECTORIES(${PORTAUDIO_SYS_INCLUDE_DIR})
+ SET (PORTAUDIO_LIBRARY ${PORTAUDIO_SYS_LIBRARY})
+ ENDIF (FORCE_BUNDLED_PORTAUDIO OR NOT SYSTEM_PORTAUDIO_AVAILABLE)
+-ADD_DEFINITIONS( -DHAVE_PORTAUDIO19)
++ADD_DEFINITIONS( -DHAVE_PORTAUDIO18)
+ SET(OPTIONAL_LIBS ${OPTIONAL_LIBS} ${PORTAUDIO_LIBRARY})
+ IF (APPLE)
+ FIND_LIBRARY(COREAUDIO_LIBRARY CoreAudio)
+@@ -245,7 +245,7 @@
+ ######################################################################
+ # LLVM Support
+ ######################################################################
+-OPTION(USE_LLVM "Build with LLVM support?" ON)
++OPTION(USE_LLVM "Build with LLVM support?" OFF)
+
+ IF( USE_LLVM )
+ set(LLVM_FOUND FALSE)
diff --git a/math/freemat/files/patch-configure b/math/freemat/files/patch-configure
deleted file mode 100644
index 8cda9f919fab..000000000000
--- a/math/freemat/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Mar 26 00:30:19 2007
-+++ configure Sun Apr 15 23:57:15 2007
-@@ -5442,7 +5442,7 @@
- fi
- fi
- is_win32="false"
-- platform="--linux"
-+ platform="--freebsd"
-
- # Check whether --with-ncurses or --without-ncurses was given.
- if test "${with_ncurses+set}" = set; then
diff --git a/math/freemat/files/patch-libs__libFN__CMakeLists.txt b/math/freemat/files/patch-libs__libFN__CMakeLists.txt
new file mode 100644
index 000000000000..85fdf248f44f
--- /dev/null
+++ b/math/freemat/files/patch-libs__libFN__CMakeLists.txt
@@ -0,0 +1,15 @@
+--- ./libs/libFN/CMakeLists.txt.orig 2009-11-13 20:28:30.000000000 -0500
++++ ./libs/libFN/CMakeLists.txt 2009-11-13 22:38:43.000000000 -0500
+@@ -13,6 +13,12 @@
+ mathfunc4.cpp
+ )
+ ENDIF( MSVC )
++
++IF (${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
++ SET(LIBM_FILES
++ mathfunc4.cpp
++ )
++ENDIF(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+
+ ADD_LIBRARY( FN
+ FNFun.cpp
diff --git a/math/freemat/files/patch-libs__libFN__FNFun.cpp b/math/freemat/files/patch-libs__libFN__FNFun.cpp
new file mode 100644
index 000000000000..6e8498d5f61b
--- /dev/null
+++ b/math/freemat/files/patch-libs__libFN__FNFun.cpp
@@ -0,0 +1,17 @@
+--- ./libs/libFN/FNFun.cpp.orig 2009-11-14 18:51:06.000000000 -0500
++++ ./libs/libFN/FNFun.cpp 2009-11-14 20:26:43.000000000 -0500
+@@ -35,6 +35,14 @@
+ double trunc( double x );
+ float truncf( float x );
+ #endif
++#if defined(__FreeBSD__)
++#ifdef __cplusplus
++extern "C" {
++ float lgammaf(float x);
++ float tgammaf(float x);
++}
++#endif
++#endif
+
+ //!
+ //@Module ERFC Complimentary Error Function
diff --git a/math/freemat/files/patch-libs__libFN__fdlibm.h b/math/freemat/files/patch-libs__libFN__fdlibm.h
new file mode 100644
index 000000000000..b593321edd78
--- /dev/null
+++ b/math/freemat/files/patch-libs__libFN__fdlibm.h
@@ -0,0 +1,17 @@
+--- ./libs/libFN/fdlibm.h.orig 2009-11-14 19:26:54.000000000 -0500
++++ ./libs/libFN/fdlibm.h 2009-11-14 19:27:53.000000000 -0500
+@@ -11,13 +11,11 @@
+ */
+
+ /* REDHAT LOCAL: Include files. */
++#include <stdarg.h>
+ #include <math.h>
+ //#include <sys/types.h>
+ //#include <machine/ieeefp.h>
+
+-typedef __int32 __int32_t;
+-typedef unsigned __int32 __uint32_t;
+-
+ #define __IEEE_LITTLE_ENDIAN
+
+ /* REDHAT LOCAL: Default to XOPEN_MODE. */
diff --git a/math/freemat/files/patch-libs_libCore_MatIO.hpp b/math/freemat/files/patch-libs_libCore_MatIO.hpp
deleted file mode 100644
index c16283c7e2cb..000000000000
--- a/math/freemat/files/patch-libs_libCore_MatIO.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libCore/MatIO.hpp.orig 2009-10-08 10:01:46.000000000 +0700
-+++ libs/libCore/MatIO.hpp 2009-10-08 10:20:30.000000000 +0700
-@@ -4,6 +4,7 @@
- #include "Array.hpp"
- #include <string>
- #include <zlib.h>
-+#include <stdio.h>
-
- using namespace std;
-
diff --git a/math/freemat/files/patch-libs_libFN_FNFun.cpp b/math/freemat/files/patch-libs_libFN_FNFun.cpp
deleted file mode 100644
index 9cabe75429a5..000000000000
--- a/math/freemat/files/patch-libs_libFN_FNFun.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./libs/libFN/FNFun.cpp.orig 2008-03-14 16:43:05.000000000 +0100
-+++ ./libs/libFN/FNFun.cpp 2008-03-18 22:05:39.000000000 +0100
-@@ -23,6 +23,15 @@
- #include "Malloc.hpp"
- #include <math.h>
-
-+#if defined(__FreeBSD__) && __FreeBSD_version < 800022
-+float
-+tgammaf(float x)
-+{
-+
-+ return (tgamma(x));
-+}
-+#endif
-+
- //!
- //@Module ERFC Complimentary Error Function
- //@@Section MATHFUNCTIONS
diff --git a/math/freemat/files/patch-libs_libFreeMat_Array.cpp b/math/freemat/files/patch-libs_libFreeMat_Array.cpp
deleted file mode 100644
index 646d2666d355..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_Array.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/libFreeMat/Array.cpp.orig 2009-10-08 09:37:54.000000000 +0700
-+++ libs/libFreeMat/Array.cpp 2009-10-08 09:38:20.000000000 +0700
-@@ -27,6 +27,8 @@
- #include <math.h>
- #include <stdio.h>
- #include <set>
-+#include <algorithm>
-+#include <functional>
-
- #include "FunctionDef.hpp"
- #include "NumericArray.hpp"
diff --git a/math/freemat/files/patch-libs_libFreeMat_IEEEFP.cpp b/math/freemat/files/patch-libs_libFreeMat_IEEEFP.cpp
deleted file mode 100644
index 124c091ebec1..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_IEEEFP.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libFreeMat/IEEEFP.cpp.orig 2009-10-08 09:42:00.000000000 +0700
-+++ libs/libFreeMat/IEEEFP.cpp 2009-10-08 09:43:46.000000000 +0700
-@@ -17,6 +17,7 @@
- *
- */
- #include "IEEEFP.hpp"
-+#include <stdio.h>
-
- static bool endianDetected = false;
- static bool bigEndian = false;
diff --git a/math/freemat/files/patch-libs_libFreeMat_Malloc.cpp b/math/freemat/files/patch-libs_libFreeMat_Malloc.cpp
deleted file mode 100644
index 4f0b098d2a8c..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_Malloc.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libFreeMat/Malloc.cpp.orig 2009-10-08 09:45:59.000000000 +0700
-+++ libs/libFreeMat/Malloc.cpp 2009-10-08 09:47:56.000000000 +0700
-@@ -21,6 +21,7 @@
- #include "Exception.hpp"
- #include <stdlib.h>
- #include <stdio.h>
-+#include <cstring>
-
-
- void* Malloc(int count) {
diff --git a/math/freemat/files/patch-libs_libFreeMat_Scanner.cpp b/math/freemat/files/patch-libs_libFreeMat_Scanner.cpp
deleted file mode 100644
index 6fb554ad4b13..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_Scanner.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libFreeMat/Scanner.cpp.orig 2009-10-08 09:51:15.000000000 +0700
-+++ libs/libFreeMat/Scanner.cpp 2009-10-08 09:51:25.000000000 +0700
-@@ -4,6 +4,7 @@
- #include <stdlib.h>
- #include <ctype.h>
- #include "Exception.hpp"
-+#include <algorithm>
-
- extern string fm_reserved[];
- extern int fm_reserved_count;
diff --git a/math/freemat/files/patch-libs_libFreeMat_Scope.hpp b/math/freemat/files/patch-libs_libFreeMat_Scope.hpp
deleted file mode 100644
index 53e2a1019211..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_Scope.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libFreeMat/Scope.hpp.orig 2009-10-08 09:40:36.000000000 +0700
-+++ libs/libFreeMat/Scope.hpp 2009-10-08 09:40:55.000000000 +0700
-@@ -25,6 +25,7 @@
- */
- #include <string>
- #include <QMutex>
-+#include <algorithm>
-
- #include "Array.hpp"
- #include "SymbolTable.hpp"
diff --git a/math/freemat/files/patch-libs_libFreeMat_Token.cpp b/math/freemat/files/patch-libs_libFreeMat_Token.cpp
deleted file mode 100644
index ccde44cf1aeb..000000000000
--- a/math/freemat/files/patch-libs_libFreeMat_Token.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/libFreeMat/Token.cpp.orig 2009-10-08 09:49:12.000000000 +0700
-+++ libs/libFreeMat/Token.cpp 2009-10-08 09:50:12.000000000 +0700
-@@ -2,6 +2,7 @@
- #include "Serialize.hpp"
- #include <iostream>
- #include <errno.h>
-+#include <climits>
-
- // These must appear as sequential token numbers
- string fm_reserved[22] = {
diff --git a/math/freemat/files/patch-libs_libGraphics_HandleAxis.cpp b/math/freemat/files/patch-libs_libGraphics_HandleAxis.cpp
deleted file mode 100644
index 979b6fc07442..000000000000
--- a/math/freemat/files/patch-libs_libGraphics_HandleAxis.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./libs/libGraphics/HandleAxis.cpp.orig Thu Dec 28 15:02:22 2006
-+++ ./libs/libGraphics/HandleAxis.cpp Sat Feb 10 00:07:46 2007
-@@ -28,6 +28,10 @@
- #include "HandleCommands.hpp"
- #include <qgl.h>
-
-+#ifdef __FreeBSD__
-+#define log2(x) log(x)/log(2)
-+#endif
-+
- // Property list & status
- // activepositionproperty
- // alim