aboutsummaryrefslogtreecommitdiff
path: root/math/freemat
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-04-21 14:50:16 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-04-21 14:50:16 +0000
commitaf692e50ba1276c608e3cfa78958642fba98ab05 (patch)
tree993a5b7d38595d1701fe0dbd9fa3564bd2b4efeb /math/freemat
parent5385121bf690945e06d9191a8026fa74fbf99c10 (diff)
Notes
Diffstat (limited to 'math/freemat')
-rw-r--r--math/freemat/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 725441c46699..c587d092f82c 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -7,8 +7,8 @@
PORTNAME= FreeMat
PORTVERSION= 4.0
-PORTREVISION= 1
DISTVERSIONSUFFIX= -Source
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= SF
MASTER_SITE_SUBDIR= freemat/FreeMat4
@@ -94,11 +94,17 @@ pre-everything::
@${ECHO_MSG} '**********************************************************'
.endif
+# Get rid of the generated .moc.cpp files included in the
+# upstream distro. They should be regenerated with the
+# currently-installed version of moc-qt4.
+post-extract:
+ @cd ${WRKSRC} && ${FIND} . -name \*.moc.cpp -delete
+
pre-configure:
${RM} ${WRKSRC}/CMakeCache.txt
+# Avoid conflict with QT3
post-configure:
- # Avoid conflict with QT3
${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e '/^QT_CFLAGS/s|-I${LOCALBASE}/include ||'