aboutsummaryrefslogtreecommitdiff
path: root/math/freemat
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-02-14 12:44:23 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-02-14 12:44:23 +0000
commit205f1ac23dd674163b211b136715384d89c1bf4d (patch)
tree9c81baefcee3d377ac0c3395066592b349bb4959 /math/freemat
parent3a5a5a3b60daa9f939e7761f8990e8956b5db1b3 (diff)
downloadports-205f1ac23dd674163b211b136715384d89c1bf4d.tar.gz
ports-205f1ac23dd674163b211b136715384d89c1bf4d.zip
Notes
Diffstat (limited to 'math/freemat')
-rw-r--r--math/freemat/Makefile4
-rw-r--r--math/freemat/files/patch-libs__thirdparty__pcre__pcreposix.c12
2 files changed, 14 insertions, 2 deletions
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 77472ed68aeb..32ad006dadda 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= FreeMat
PORTVERSION= 4.0
DISTVERSIONSUFFIX= -Source
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math science
MASTER_SITES= SF
MASTER_SITE_SUBDIR= freemat/FreeMat4
@@ -20,7 +20,7 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= An environment for rapid engineering and scientific processing
LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack \
- pcre.0:${PORTSDIR}/devel/pcre
+ pcre.1:${PORTSDIR}/devel/pcre
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LICENSE= GPLv2
diff --git a/math/freemat/files/patch-libs__thirdparty__pcre__pcreposix.c b/math/freemat/files/patch-libs__thirdparty__pcre__pcreposix.c
new file mode 100644
index 000000000000..fc1d28b76a56
--- /dev/null
+++ b/math/freemat/files/patch-libs__thirdparty__pcre__pcreposix.c
@@ -0,0 +1,12 @@
+--- libs/thirdparty/pcre/pcreposix.c.orig 2012-02-14 11:08:58.826982602 +0100
++++ libs/thirdparty/pcre/pcreposix.c 2012-02-14 11:09:36.105982836 +0100
+@@ -238,7 +238,8 @@
+
+ if (preg->re_pcre == NULL) return eint[errorcode];
+
+-preg->re_nsub = pcre_info((const pcre *)preg->re_pcre, NULL, NULL);
++pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
++ PCRE_INFO_CAPTURECOUNT, &(preg->re_nsub));
+ return 0;
+ }
+