aboutsummaryrefslogtreecommitdiff
path: root/math/freemat
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 20:39:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-05-30 20:39:12 +0000
commit3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5 (patch)
treec6487f309b5d29e868c4ea46df98e320c50df957 /math/freemat
parent0b206685de74445cde7f184f18a43c7ac16172a6 (diff)
downloadports-3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5.tar.gz
ports-3fef6c52f0fc4ef44d16f7c2f73fab20c9c251e5.zip
Notes
Diffstat (limited to 'math/freemat')
-rw-r--r--math/freemat/Makefile4
-rw-r--r--math/freemat/files/patch-CMakeLists.txt9
2 files changed, 2 insertions, 11 deletions
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 2b0019aa0d27..10876b99764a 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -4,7 +4,7 @@
PORTNAME= FreeMat
PORTVERSION= 4.2
DISTVERSIONSUFFIX= -Source
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math science
MASTER_SITES= SF/freemat/FreeMat4
@@ -21,7 +21,7 @@ LIB_DEPENDS= libarpack.so:${PORTSDIR}/math/arpack \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
libpcre.so:${PORTSDIR}/devel/pcre \
- libportaudio.so.0:${PORTSDIR}/audio/portaudio \
+ libportaudio.so:${PORTSDIR}/audio/portaudio \
libumfpack.so:${PORTSDIR}/math/suitesparse
USES= blaslapack cmake:outsource dos2unix fortran pkgconfig python:build
diff --git a/math/freemat/files/patch-CMakeLists.txt b/math/freemat/files/patch-CMakeLists.txt
index 8ab3a7e755fe..5414cad9027c 100644
--- a/math/freemat/files/patch-CMakeLists.txt
+++ b/math/freemat/files/patch-CMakeLists.txt
@@ -1,14 +1,5 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
-@@ -204,7 +204,7 @@
- FIND_PACKAGE(PORTAUDIO)
-
- if (PORTAUDIO_FOUND)
-- ADD_DEFINITIONS(-DHAVE_PORTAUDIO19)
-+ ADD_DEFINITIONS(-DHAVE_PORTAUDIO18)
- SET(OPTIONAL_LIBS ${OPTIONAL_LIBS} ${PORTAUDIO_LIBS})
- INCLUDE_DIRECTORIES(${PORTAUDIO_INCLUDE})
- endif()
@@ -257,7 +257,7 @@
add_definitions(-DHAVE_LLVM)
include_directories(${LLVM_INCLUDE_DIRS})