aboutsummaryrefslogtreecommitdiff
path: root/math/fxt
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-07-26 18:55:14 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-07-26 18:55:14 +0000
commit9724fbcdf16eec7d864b2d12ab3cdf25a1ec86e5 (patch)
treef69eca384b731117fd60066d4e302d065724fda7 /math/fxt
parent9daf6f3446ed4ebb5a680854d5df7ca39c8de023 (diff)
downloadports-9724fbcdf16eec7d864b2d12ab3cdf25a1ec86e5.tar.gz
ports-9724fbcdf16eec7d864b2d12ab3cdf25a1ec86e5.zip
Notes
Diffstat (limited to 'math/fxt')
-rw-r--r--math/fxt/Makefile2
-rw-r--r--math/fxt/distinfo4
-rw-r--r--math/fxt/pkg-plist20
3 files changed, 21 insertions, 5 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index df5e1a7f1595..33141e0ebbca 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fxt
-PORTVERSION= 2011.06.26
+PORTVERSION= 2011.07.24
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
EXTRACT_SUFX= .tgz
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index 00bce4717fb7..df29b8793b30 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fxt-2011.06.26.tgz) = fe5b2243383f4fcbe20bcbad9a48e3ace52ef85499bd647cb3c0dcaa75af8ed5
-SIZE (fxt-2011.06.26.tgz) = 1310558
+SHA256 (fxt-2011.07.24.tgz) = 586c824b95ef098d92cc0eca58ec17d35414012b961ef2f95813389d1f8111ad
+SIZE (fxt-2011.07.24.tgz) = 1323794
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
index 6bbd9257c404..8227b923e7e3 100644
--- a/math/fxt/pkg-plist
+++ b/math/fxt/pkg-plist
@@ -47,6 +47,8 @@ include/fxt/aux2/scale2d.h
include/fxt/aux2/shift2d.h
include/fxt/aux2/transpose.h
include/fxt/aux2/transpose2.h
+include/fxt/bits/print-bin.h
+include/fxt/bits/radix-m4.h
include/fxt/bits-all.h
include/fxt/bits/average.h
include/fxt/bits/bin2naf.h
@@ -120,8 +122,6 @@ include/fxt/bits/nextgray.h
include/fxt/bits/parenwords.h
include/fxt/bits/parity.h
include/fxt/bits/pcrc64.h
-include/fxt/bits/printbin.h
-include/fxt/bits/printbitset.h
include/fxt/bits/revbin-upd.h
include/fxt/bits/revbin.h
include/fxt/bits/revgraycode.h
@@ -134,6 +134,7 @@ include/fxt/bmat-all.h
include/fxt/bmat/bitmat-funcs.h
include/fxt/bmat/bitmat-inline.h
include/fxt/bpol-all.h
+include/fxt/bpol/mersenne-coprime.h
include/fxt/bpol/all-irredpoly.h
include/fxt/bpol/bitpol-arith.h
include/fxt/bpol/bitpol-degree.h
@@ -165,6 +166,7 @@ include/fxt/bpol/poly-tab.h
include/fxt/chirpzt-all.h
include/fxt/chirpzt/chirpzt.h
include/fxt/comb-all.h
+include/fxt/comb/perm-st-pref.h
include/fxt/comb/big-fact2perm.h
include/fxt/comb/binary-debruijn.h
include/fxt/comb/binary-necklace.h
@@ -298,6 +300,7 @@ include/fxt/correlation/slowcorr.h
include/fxt/dctdst-all.h
include/fxt/dctdst/dctdst.h
include/fxt/ds-all.h
+include/fxt/ds/priorityqueue1.h
include/fxt/ds/bitarray.h
include/fxt/ds/coroutine.h
include/fxt/ds/deque.h
@@ -515,6 +518,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arith/zero-divisors-func-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arith/zero-divisors-func-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arith/zero-divisors-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/radix-m4-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/radix-m4-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/all-dbs-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/all-dbs-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/bin2naf-demo.cc
@@ -644,6 +649,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/thue-morse-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/zorder-texpic-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/zorder-texpic-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/perm-st-pref-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/perm-st-pref-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/acgray-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/acgray-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/bell-number-demo.cc
@@ -1012,6 +1019,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fft/walsh-bench.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fft/walsh-eigenvec-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fft/walsh-eigenvec-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/lfsr-trace0-generators-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/lfsr-trace0-generators-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/all-irredpoly-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/all-irredpoly-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/all-normalpoly-demo.cc
@@ -1078,6 +1087,12 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/primefact-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/qmatrix-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gf2n/qmatrix-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-debruijn-m-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-perm-pref-rot-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-perm-pref-rot-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-perm-pref-rev-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-debruijn-m-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-perm-pref-rev-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-acgray-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-acgray-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph/graph-complementshift-demo.cc
@@ -1180,6 +1195,7 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sort/symbolify-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sort/unique-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sort/unique-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nextarg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/topics.txt
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sort
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/perm