aboutsummaryrefslogtreecommitdiff
path: root/math/fxt
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2010-10-26 20:22:39 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2010-10-26 20:22:39 +0000
commit49e35d11ee71a56e442a33b83dbc93020ae6d10b (patch)
tree897074fcfca05a8da06acb0180308e5f5e7975ea /math/fxt
parent280f42698d4da61ac26a204cd6d4406d79519969 (diff)
downloadports-49e35d11ee71a56e442a33b83dbc93020ae6d10b.tar.gz
ports-49e35d11ee71a56e442a33b83dbc93020ae6d10b.zip
Notes
Diffstat (limited to 'math/fxt')
-rw-r--r--math/fxt/Makefile2
-rw-r--r--math/fxt/distinfo6
-rw-r--r--math/fxt/files/patch-src__fxtalloca.h18
3 files changed, 22 insertions, 4 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index a54f83652867..650c3d82057b 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fxt
-PORTVERSION= 2010.06.15
+PORTVERSION= 2010.10.25
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
EXTRACT_SUFX= .tgz
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index 66158908b091..28e41ed98149 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,3 +1,3 @@
-MD5 (fxt-2010.06.15.tgz) = 79cc6c4632a617e50c6e6a56af1840af
-SHA256 (fxt-2010.06.15.tgz) = 28af9b338d5079ad0f9f74055cc5cc95f946db8eff411f41c04d9e45b3f3f970
-SIZE (fxt-2010.06.15.tgz) = 1220369
+MD5 (fxt-2010.10.25.tgz) = cc202619b81a7793f59ec17483daf65a
+SHA256 (fxt-2010.10.25.tgz) = 66dd959c3174d8cfb646777c5b456882a78b373c14498c5f5b7d771c3b894d55
+SIZE (fxt-2010.10.25.tgz) = 1300397
diff --git a/math/fxt/files/patch-src__fxtalloca.h b/math/fxt/files/patch-src__fxtalloca.h
new file mode 100644
index 000000000000..6b2480a3ccfc
--- /dev/null
+++ b/math/fxt/files/patch-src__fxtalloca.h
@@ -0,0 +1,18 @@
+--- ./src/fxtalloca.h.orig 2010-10-26 21:49:13.000000000 +0200
++++ ./src/fxtalloca.h 2010-10-26 21:49:58.000000000 +0200
+@@ -16,13 +16,13 @@
+ #if defined __GNUC__ // GNU compiler
+ #define ALLOCA(Type, v, n) Type v[n]
+ #else // __GNUC__
+-#include <alloca.h>
++#include <stdlib.h>
+ #define ALLOCA(Type, v, n) Type *v = (Type *)alloca((n)*sizeof(Type))
+ #endif // __GNUC__
+
+ #ifdef FORCE_ALLOCA_H
+ #undef ALLOCA
+-#include <alloca.h>
++#include <stdlib.h>
+ #define ALLOCA(Type, v, n) Type *v = (Type *)alloca((n)*sizeof(Type))
+ #endif
+