aboutsummaryrefslogtreecommitdiff
path: root/math/gambit/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-06-24 10:42:25 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-06-24 10:42:25 +0000
commit86fa7b57e504b87bff735a2e20d823c77cc342fb (patch)
treeb2de0374abfb171a8853ad990917b05ad1136de0 /math/gambit/Makefile
parentfc1f4c8dbf5c22d2e2ab34bc6d62f2df5e4c11b1 (diff)
downloadports-86fa7b57e504b87bff735a2e20d823c77cc342fb.tar.gz
ports-86fa7b57e504b87bff735a2e20d823c77cc342fb.zip
Notes
Diffstat (limited to 'math/gambit/Makefile')
-rw-r--r--math/gambit/Makefile30
1 files changed, 8 insertions, 22 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 7d5483c0ab7b..41c0f00135f1 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -1,34 +1,20 @@
-# ex:ts=8
-# Ports collection makefile for: gambit
-# Date created: Feb 8, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gambit
-PORTVERSION= 0.2010.09.01
-PORTREVISION= 1
+PORTVERSION= 13.0.0
CATEGORIES= math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
+MASTER_SITES= SF/gambit/${PORTNAME}13/${PORTVERSION}/
MAINTAINER= gahr@FreeBSD.org
COMMENT= A library of tools for doing computation in game theory
+LICENSE= GPLv2
+
USE_GNOME= gtk20
-WANT_UNICODE= yes
-USE_WX= 2.6+
-USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
+USE_WX= 2.8+
USE_LDCONFIG= yes
-
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-.if !defined(CFLAGS) || ${CFLAGS:M-fno-strict-aliasing*} == ""
-CFLAGS+= -O2 -fno-strict-aliasing
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.include <bsd.port.mk>