aboutsummaryrefslogtreecommitdiff
path: root/math/gambit
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:14:34 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:14:34 +0000
commit496390c22c363163399827dc8bdd2f264a83cc5e (patch)
treecdba8eef86caaf686cd25e926d017609571dbb1d /math/gambit
parent8eec740ab08623d0dafedd133ebcd290a711d40a (diff)
downloadports-496390c22c363163399827dc8bdd2f264a83cc5e.tar.gz
ports-496390c22c363163399827dc8bdd2f264a83cc5e.zip
Notes
Diffstat (limited to 'math/gambit')
-rw-r--r--math/gambit/Makefile14
-rw-r--r--math/gambit/distinfo4
-rw-r--r--math/gambit/files/patch-gnulib.h24
-rw-r--r--math/gambit/files/patch-sources-tools-enumpoly-double.cc10
-rw-r--r--math/gambit/pkg-plist17
5 files changed, 36 insertions, 33 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 3566d863ae97..d24014994f30 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gambit
-PORTVERSION= 0.97.0.7
-PORTREVISION= 1
+PORTVERSION= 0.2005.06.13
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,11 +15,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library of tools for doing computation in game theory
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
+LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
USE_X_PREFIX= yes
+USE_GNOME= gnometarget gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= WX_CONFIG=${X11BASE}/bin/wxgtk2-2.4-config
-MAKE_ENV= WX_CONFIG=${X11BASE}/bin/wxgtk2-2.4-config
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
+MAKE_ENV= WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
+
+CPPFLAGS= ${PTHREAD_CFLAGS}
+LDFLAGS= ${PTHREAD_LIBS}
.include <bsd.port.mk>
diff --git a/math/gambit/distinfo b/math/gambit/distinfo
index 5f0c33fca74d..1d845c704938 100644
--- a/math/gambit/distinfo
+++ b/math/gambit/distinfo
@@ -1,2 +1,2 @@
-MD5 (gambit-0.97.0.7.tar.gz) = cbdc41473214155d046afcd3b5dd78d2
-SIZE (gambit-0.97.0.7.tar.gz) = 870379
+MD5 (gambit-0.2005.06.13.tar.gz) = 6cc3a48aa2f85f0485ff4c09ba01d483
+SIZE (gambit-0.2005.06.13.tar.gz) = 846191
diff --git a/math/gambit/files/patch-gnulib.h b/math/gambit/files/patch-gnulib.h
deleted file mode 100644
index c0889b2e39aa..000000000000
--- a/math/gambit/files/patch-gnulib.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- sources/math/gnulib.h.orig Sun Feb 9 01:54:27 2003
-+++ sources/math/gnulib.h Sun Feb 9 01:56:12 2003
-@@ -32,9 +32,6 @@
- #ifndef GNULIB_H
- #define GNULIB_H
-
--#if defined(__GNUG__) && !defined(__APPLE_CC__)
--#include <_G_config.h>
--#endif // __GNUG__
- #include <stddef.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -46,11 +43,6 @@
- #include <errno.h>
- #include <fcntl.h>
-
--#if defined(__GNUG__) && !defined(__APPLE_CC__)
--extern "C" {
--int strcasecmp _G_ARGS((const char*, const char*));
--}
--#endif // __GNUG__
-
-
- #include <math.h>
diff --git a/math/gambit/files/patch-sources-tools-enumpoly-double.cc b/math/gambit/files/patch-sources-tools-enumpoly-double.cc
new file mode 100644
index 000000000000..babde63ec097
--- /dev/null
+++ b/math/gambit/files/patch-sources-tools-enumpoly-double.cc
@@ -0,0 +1,10 @@
+--- sources/tools/enumpoly/double.cc.orig Thu Jun 9 02:47:34 2005
++++ sources/tools/enumpoly/double.cc Sun Jul 3 23:39:27 2005
+@@ -28,6 +28,7 @@
+ #pragma implementation
+ #endif
+
++#include <stdio.h>
+ #include <math.h>
+ #include <float.h>
+ #include <assert.h>
diff --git a/math/gambit/pkg-plist b/math/gambit/pkg-plist
index c48d83711013..133995441243 100644
--- a/math/gambit/pkg-plist
+++ b/math/gambit/pkg-plist
@@ -1,3 +1,16 @@
bin/gambit
-bin/gcl
-bin/wxgcl
+bin/gambit-efg-enumpoly
+bin/gambit-efg-enumpure
+bin/gambit-efg-lcp
+bin/gambit-efg-liap
+bin/gambit-efg-logit
+bin/gambit-efg-lp
+bin/gambit-nfg-enummixed
+bin/gambit-nfg-enumpoly
+bin/gambit-nfg-enumpure
+bin/gambit-nfg-lcp
+bin/gambit-nfg-liap
+bin/gambit-nfg-logit
+bin/gambit-nfg-lp
+bin/gambit-nfg-mixdom
+bin/gambit-nfg-simpdiv